This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Diego Pereira 5 months, 1 week ago.

Assigned support staff: Diego Pereira.

Author Posts
May 9, 2019 at 3:56 pm #3777881

johanM-9

We have used WPML for a couple of days and it works perfect but today we got problems some of our pages are blank: hidden link and some are blank and redirect to english in the url?? hidden link

I have panic couse it is a public site, can you please help us.

May 9, 2019 at 5:00 pm #3778225

johanM-9

Please help!!

May 9, 2019 at 6:15 pm #3778671

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @johanm-9, welcome to the WPML support Forum!

Please try the following:
- Disable the "Redirection" plugin (it may be a compatibility issue)
- Go to Settings > Permalinks and re-save the permalink structure

Please let me know if it worked for you.

All the best,
Diego

May 9, 2019 at 6:20 pm #3778725

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

If the issue persist after the steps I suggested, please follow the procedures of the last private message.

Kind regards,
Diego

May 10, 2019 at 7:17 am #3781919
johanM-9

Hi,
I notice a problem between the plugin Yoast and WPML, when I deactive YOAST everything seems to work. The problem is that we need YOAST. I notice still problem with some pages. Ex. hidden link scroll down to footer and click the flag for english it is still swedish but when a click on the flag at the startpage and go to the same page in the menu it works? Do you have any ideas how we can solve the problems above?

New threads created by Diego Pereira and linked to this one are listed below:

https://wpml.org/forums/topic/split-issue-with-language-switcher/

May 10, 2019 at 6:04 pm #3787397

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I checked the settings of your server through debug log and saw that some items need attention:
PHP version
Upgrade the PHP to version 7 or higher. This is a practice recommended by the WordPress.org website: https://wordpress.org/about/requirements/

Increase WP memory
Please increase the PHP memory limit to 256mb. Currently this memory is set to 128mb.
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

MaxInputVars
Currently your server is configured with MaxInputVars = 1000, which is too low and can cause problems. Please increase this to 10,000. There are two options to do this:
== php.ini file
Open the php.ini file and insert/edit this line:

max_input_vars = 10000

hidden link
== .htaccess file

php_value max_input_vars 10000

Please also check this WPML + YOAST tutorial: https://wpml.org/documentation/plugins-compatibility/using-wordpress-seo-with-wpml/ - Please make sure to have all required plugins.

Regarding the issue with the language switcher, as it's a different issue, I will create a new ticket for it. I will reply in the new ticket.

Kind regards,
Diego