This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 3.18 hours from now. Thank you for your understanding.

This topic contains 5 replies, has 2 voices.

Last updated by Carlos Rojas 1 year ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 20, 2018 at 9:15 pm #2753310

Dan

Tell us what you are trying to do?

I'm trying to send a post out for translation from the "Translation Basket" tab in Translation Management.

NOTE - The service worked perfectly fine for me today to send a blog post off to TranslateMedia. That job is now being processed. About 30 minutes later, I went to send off a second post for translation, and ran into this issue I am documenting here.

From the Translation Dashboard, I add a post to the Translation Basket. I then go into that tab and press "Send all items for translation". It goes through the steps that seem to be sending to the system, and then it gives me this message:
-----
Done!

Batch # 1
(12) Invalid state 'translating' to complete operation
Rollback jobs...
Batch rolled back
-----

The communication log for the session is below. I have tried adjusting the date, modifying the batch name - and nothing seems to work. I still get this error.

The post in question is a draft post that has not yet been published.

-----------
09/20/2018 09:10:48 pm - call - hidden link - {"api_version":1.100000000000000088817841970012523233890533447265625,"batch_id":19379,"job":{"file":"UNDISCLOSED","word_count":390,"title":"What\u2019s Ahead at the 2018 Plenipotentiary Conference","cms_id":"post_87211_en_fr","udid":"61363637-3861-5163-b764-333935653866","url":"https:\/\/www.internetsociety.org?p=87211&preview=true&preview_id=87211","translator_id":0,"note":"","source_language":"en","target_language":"fr"},"accesskey":"UNDISCLOSED"}
09/20/2018 09:10:49 pm - response - {"status":{"code":31,"message":"The job with given cms_id already exists in this batch","debug":""},"response":null}
09/20/2018 09:10:49 pm - error - (31) The job with given cms_id already exists in this batch
09/20/2018 09:10:50 pm - call - hidden link - {"api_version":1.100000000000000088817841970012523233890533447265625,"batch_id":19379,"job":{"file":"UNDISCLOSED","word_count":390,"title":"What\u2019s Ahead at the 2018 Plenipotentiary Conference","cms_id":"post_87211_en_es","udid":"35613634-6435-5136-a163-363638613639","url":"https:\/\/www.internetsociety.org?p=87211&preview=true&preview_id=87211","translator_id":0,"note":"","source_language":"en","target_language":"es"},"accesskey":"UNDISCLOSED"}
09/20/2018 09:10:51 pm - response - {"status":{"code":31,"message":"The job with given cms_id already exists in this batch","debug":""},"response":null}
09/20/2018 09:10:51 pm - error - (31) The job with given cms_id already exists in this batch
09/20/2018 09:10:53 pm - call - hidden link - {"api_version":1.100000000000000088817841970012523233890533447265625,"project_id":7665,"accesskey":"UNDISCLOSED","batch_id":19379}
09/20/2018 09:10:53 pm - response - {"status":{"code":12,"message":"Invalid state 'translating' to complete operation","debug":""},"response":null}
09/20/2018 09:10:53 pm - error - (12) Invalid state 'translating' to complete operation

-----------
Is there any documentation that you are following?

Just using the interface as I have done before.

Is there a similar example that we can see?

What is the link to your site?

hidden link

September 20, 2018 at 9:19 pm #2753325

Dan

I will note that I tried this in both Mozilla Firefox and Google Chrome to see if there was a browser issue.

Additionally, after reading a few posts online with people who seem to have a similar problem, I tried clearing the cache for this page (given that we have Amazon's Cloudfront CDN in front of our site). However, that did not seem to make any difference.

September 21, 2018 at 7:29 pm #2756398

Dan

Another post on this issue is this one:

https://wpml.org/forums/topic/i-get-an-error-when-trying-to-send-items-for-translation-from-translation-basket/

I did trying clearing the cache for a page and that did not seem to change anything. I have no tried adding that directive to wp-config.php yet.

September 21, 2018 at 8:15 pm #2756474

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I would like to ask you to follow this steps:
- Create a full backup of the site before making any change.
- Update all outdated plugins and themes, specially WPML plugins.
- Add this code to the wp-config.php file:

define( 'ICL_DISABLE_CACHE', true );

- If the issue persists I kindly ask you to re-create the page (this new page will have a different ID) and double check if the issue persists.

Could you tell me the result of this steps?

Kind regards,
Carlos

October 1, 2018 at 8:53 pm #2779483

Dan

Unfortunately I missed the note that this thread was being marked as "Resolved". It is not yet resolved and I opened a new ticket:

https://wpml.org/forums/topic/still-getting-error-12-invalid-state-translating-to-complete-operation/

October 1, 2018 at 9:19 pm #2779536

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I just took your new ticket. We will continue from there 🙂

Regards,
Carlos