This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 27 replies, has 2 voices.

Last updated by Marcel 4 months, 3 weeks ago.

Assigned support staff: Marcel.

Author Posts
May 26, 2019 at 4:28 pm #3892071

sabrinaM-3

I am trying to: When I go to the sublanguage from Home page: works
When I go in a page to the translation: error 404

Link to a page where the issue can be seen:
hidden link

I expected to see: the English translation

Instead, I got:404

String translation:
I can not translate all - string not found

May 27, 2019 at 8:52 am #3894861

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

Thank you for contacting WPML Support.

It looks like English is not a visible language, or there is no content translated to English. Could you please send me a specific example?

Please let me know.

Best Marcel

May 27, 2019 at 9:27 am #3895301

sabrinaM-3

That is correct
I de activated English and French language since it cause 404 error
Could you solve it if I gave my login?
Thank you
Sabrina

May 27, 2019 at 10:40 am #3896131

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

yes I would like to check this on your site. I would need to request temporary access (WP-Admin and FTP) to your site
– preferably to a test site where the problem has been replicated if possible –
in order to be of better help and check if some configurations might need to be changed

Your next answer will be private which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

✙ Please add the Links to the […] Edit Screen, the Page/Post where you insert the […] and the corresponding Front End Page/Screen

Please don't forget the FTP access, which I need to activate the PHP debugging.

Thank You.

Best Marcel

May 27, 2019 at 2:32 pm #3898395

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Sabrina,

I activated now "English" to test the issue. Please clear the basket in "Pages", as you have English and French "Home" URL endpoints deleted.

hidden link

Please run a backup before, if may you still need these pages in the future.

Best Marcel

May 27, 2019 at 5:53 pm #3900135

sabrinaM-3

I can not delete the pages: it says I have no permission
And the error 404 still is there

May 27, 2019 at 6:02 pm #3900155

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Sabrina,

I see you cleared already the pages. Thank you. I activated both languages and it looks like the error is not showing up on every request.

Your provided FTP login credentials don't open your WP installation. Could you please check this as well? I want to activate a PHP Debugging. For the moment I hide the two languages again.

Thank You

Best Marcel

May 27, 2019 at 6:44 pm #3900309

sabrinaM-3

The ftp is going to the domain?
It should go to the wp map?
Which map?

May 28, 2019 at 6:38 am #3903065

sabrinaM-3

could you send me the secure form link again?

May 28, 2019 at 7:09 am #3903209

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Sabrina,

Sure. Next answer is private again.

The folder should point to your WP installation. I added you a screenshot of what I see.

Best Marcel

May 28, 2019 at 7:49 am #3903587

sabrinaM-3

please send me the private link I have setup the ftp

May 28, 2019 at 7:50 am #3903591

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Please try again

May 28, 2019 at 9:55 am #3905039

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Sabrina,

I can't login with these credentials. I tried also with "wpml" as username and not "wipml". Next answer is private again. Otherwise, you can activate the Debugging self:

To enable it, open your wp-config.php file and look for

define('WP_DEBUG', false);

Change it to:

define('WP_DEBUG', true);

In order to enable the error logging to a file on the server you need to add yet one more similar line:

define( 'WP_DEBUG_LOG', true );

In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

define( 'WP_DEBUG_DISPLAY', true );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.
If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

Please note that you’ll see everything, not only related to our Plugins.
This will most likely include messages from other plugins, your theme and sometimes even WordPress core. The messages appear all over the place.
Sometimes they appear right on top, but they can also appear in the middle of the page.

DOC:
https://codex.wordpress.org/Debugging_in_WordPress

Please report me the errors you are seeing.

Kind Regards
Marcel

May 29, 2019 at 7:43 am #3912445

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Sabrina,

the FTP opens /wp-content. The wp-config.php is one folder outside. So it looks like this wp-config.php is a copy of the original file. The changes I did also didn't had any effect. I added first the PHP Debugging which didn't have any effect, then I modified the first line of the file, which should break the site.

Could you please check this and provide full FTP access? May your hoster can assist you in this case.

Best Marcel

May 29, 2019 at 7:58 am #3912721

sabrinaM-3

the first ftp was for access to the complete site.
I changed it to the map.
Can you send me the secure link again - I will change the ftp again.
The host can not help - they can not setup any ftp