Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Real Places search form redirecting to home page and giving 404 on translated properties Solution: -Regarding the search results: -- Translate the page "resultats" -- Use language in directories as URL format

However, changing the URL format also fix the slug problem for the English property, but broke it for the French property. To solve it: - Go to WPML > String Translation and search for "property" (exact match): -- translate inspiry-real-estate-> "property" (note the case) to propertye.

Then, both properties worked on /property/

So, I translated the slug in: WPML > Settings > Post Types Translation and it is working.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 8 replies, has 2 voices.

Last updated by yashaK 1 year, 4 months ago.

Assigned support staff: Bruno Kos.

Author Posts
April 2, 2019 at 11:10 am

yashaK

I am using the template Real Place and Wpml
The search engine is only working in the default language (French) if I search from English the result is redirected in French.
When we click on the result of proprieties that have been translated it give an error 404
I tried on local to use only Wpml and the template tried different permalink options, also tried in Wpml “Different languages in directories” and “Language name added as a parameter” this option combined with permalinks “Plain” is better with the search engine but still have a 404 error on the proprieties.
I tried with the option in WMLP “Adjust IDs for multilingual functionality” on and off, use “Use directory for default language“ and created a root page used sticky link plugin all this didn’t help
I am a developer, 3 days of test and nothing is working correctly, I read all the support forum that are related and didn’t found a solution that’s why I am calling you to my rescue.

April 2, 2019 at 3:45 pm #3518931

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Can you tell me you would be interested in setting up this on our clean Sandbox install for further testing and debugging, as this sounds like a compatibility issue to me?

Let me know and I will set it all up for you.

Regards,
Bruno Kos

April 2, 2019 at 7:31 pm #3520309

yashaK

Hy Bruno
Yes I am interested by your sandbox install.
The Real place template should be compatible with WPML both are saying that it is !
I really appreciate your help !
Yasha

April 3, 2019 at 7:42 am
April 3, 2019 at 9:13 am #3523901

yashaK

Hy Bruno
Theme Compatibility : https://wpml.org/documentation/theme-compatibility/translating-real-homes-theme-using-wpml/

I installed the theme and plugins needed, I also put the default language in french because my customer need it like this, but I think it is part of the problem.

I try to change some option of the theme but it didn't recorded them.

April 3, 2019 at 10:29 am #3524555

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

The search engine is only working in the default language (French) if I search from English the result is redirected in French.

Can you tell me if you tried this on our sandbox already, is it working? Can you set this up so that we can check?

Regards,
Bruno Kos

April 3, 2019 at 2:09 pm #3526977

yashaK

I reproduce the environment and have the two same bugs.
Search from non default language goes to french.
Translated proprieties give an error 404

April 3, 2019 at 3:58 pm #3528427

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I've escalated this to our Compatibility team and will keep you posted. I've noted the following issues:

1) Translated properties such as hidden link giving 404 (they seem to redirect the slug)
2) Search form on translated pages should be returning results from those languages

Regards,
Bruno Kos

April 5, 2019 at 9:57 am #3542827

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I have some news form compatibility team:

-Regarding the search results:
-- Translate the page "resultats"
-- Use language in directories as URL format

Is this a suitable solution for you?

However, changing the URL format also fix the slug problem for the English property, but broke it for the French property. To solve it:
- Go to WPML > String Translation and search for "property" (exact match):
-- translate inspiry-real-estate-> "property" (note the case) to propertye.

Then, both properties worked on /property/

So, I translated the slug in: WPML > Settings > Post Types Translation and it is working.

Let me know how it goes!

Regards,
Bruno Kos

April 5, 2019 at 3:17 pm #3545311

yashaK

My issue is resolved now. Thank you!