This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Bruno 1 month ago.

Assigned support staff: Bruno.

Author Posts
September 3, 2019 at 8:54 pm

Ecommerce First

I have an Error 404 on translated product page (not regular page)

Link to a page where the issue can be seen:
hidden link

I expected to see: a functionnal product page

I try these thing, but nothing solve the issue.

• Make all the plugins update
• I desactivate all the plugin (nothing happen)
• I erase the WPML cache
• I Synchronized the Taxonomies
• I erase ghost...
• I think the problem come after an former update...
• Update permalink (many time)

Need help with this.

Best regards,

Sylvain

September 3, 2019 at 11:31 pm #4507487

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. I saw the problem you are reporting. I've used the Duplicator plugin and I did a copy of your site. I will install it on my test environment and soon I will contact you.

Thank you.

September 6, 2019 at 1:22 am #4522241

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Sorry for the delay. I have submitted your ticket to 2nd tier support so they can check what may be happening. As soon as they check, we'll keep you updated.

Thank you.

September 10, 2019 at 1:37 am #4540757

Ecommerce First

So, what hapenning now, my customer need a functionnal website...

September 11, 2019 at 12:05 am #4549243

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

As I explained above, our team is still working on it. As soon as I have an answer where the problem is fixed, we will contact you.

Thank you.

September 12, 2019 at 4:05 pm #4562941

Ecommerce First

It will hurt hurt my company reputation, I can't leave the customer website not functionnal for a long period the need it solved in the best delay. Can I have an ETA ? I submit the problen since many day...

September 13, 2019 at 12:33 am #4564501

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Unfortunately, I do not have a deadline when our team will check this. At the moment you can be sure to update all plugins - we recently released updates of our plugins.

This way you can check if the problem still persists. I will again send a message to 2nd tier support, but I do not have a deadline when this will be fixed.

Sorry for the delay. As soon as I have any updates I will contact you.

Thank you.

September 13, 2019 at 1:15 am #4564545

Ecommerce First

I made the updates and the problem still there.

September 13, 2019 at 1:24 am #4564551

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. for updating the plugins. I have contacted 2nd tier support again and am waiting for their response.

As soon as I have an answer I will update you.

Thank you.

September 16, 2019 at 2:39 pm #4581607

Ecommerce First

And nobody have any news?

September 16, 2019 at 3:34 pm #4582059

Ecommerce First

For your information, I restore a former version of the website (23/08/2019) cause the customer launch the new collection for the year 2019–2020 tomorrow with journalists and they need a functional website.

But I want to solve this issue cause I don’t want to see this problem again. For this reason, I put the bugged version on this link hidden link to find the problem,cause it will come back with upgrades and we don’t want to manage this kind of problem again.

I’m seriously disappointed by the efficiency of your company to follow an important bug, you should understand it impacts my company's reputation and my customer losing sale potential for a long period.

Best regards,

Sylvain D. Desjardins

September 18, 2019 at 1:54 am #4591497

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

The 2nd tier support has verified the problem and fixed it by following the steps below:

- Go to WPML > String Translator and search for "categorie-produit". It will display 2 strings
- Change the language of "categorie-produit/%product_cat%" to french. Translate this string to "product-category/%product_cat%"
- Now change the "product-category" transation on both strings to something different (I tested with product-category2) and save
- Go to WPML > Settings, check if the translation of the "Product categories" slug is set as "product-category2" (or the slug you choose) and click on save
- Go to Settings > permalinks and re-save the permalink structure

After following these steps and changing the slug back to "product-category", products are displaying correctly in the secondary language.

Could you please check if this fixes the issue you reported?

Thank you.