This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Itamar 1 year ago.

Assigned support staff: Itamar.

Author Posts
October 15, 2018 at 7:29 am #2816408

anastasiaM

I get this message:
For String Tracking to work, the option Assume that the original language of all strings is English was automatically disabled. To enable it back, go to WPML->Theme and Plugins localization.
But when I try to set language to English I get an error saving data.

I also had an error 500 in subpages. I resaved permalinks to create htaccess again and the only difference in the two files is that the faulty one had the rewrite rule set to /el language

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /el/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /el/index.php [L]
</IfModule>

Like this

October 16, 2018 at 3:47 pm #2821675

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

'Track where strings appear on the site' issue

I could not replicate this issue on my local server on a clean WordPress installation.
If you uncheck the 'Track where strings appear on the site' in the Strings Translation section and save the setting, and only them go to WPML->Theme and Plugins localization and check the 'Assume that the original language of all strings is English' does the problem persist?

Are you getting the 'error saving data' message next to the 'Save' button?

Error 500 in subpages issue
Does saving the permalinks solved this issue or is still happening?

Thanks,
Itamar.

The topic ‘[Closed] Error 500’ is closed to new replies.