Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by andoni larrañaga 2 years, 8 months ago.

Assigned support staff: Bobby.

Author Posts
November 16, 2017 at 11:34 am #1432534

andoni larrañaga

I am trying to activate WPML String Translation plugin but I get 500 error.

Deactivating all plugins except WPML Multilingual CMS I get the same error.

I'm using latest versions of plugins and WP:
WPML Multilingual CMS: 3.8.4
WPML String Translation: 2.6.3
WordPress: 4.8.3
PHP: 7.0.25

Thanks!

November 16, 2017 at 12:17 pm #1432598

andoni larrañaga

Wordpress core updated to 4.9 but still the same error.

November 16, 2017 at 6:29 pm #1433132

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

I would need to see the detail of the error. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/

Go in your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
define('WP_DEBUG', true);

Edit your wp-config.php file and add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');

This will create an error_log.txt file in your site's root directory. Please send me its contents.

November 17, 2017 at 8:56 am #1433510

andoni larrañaga

Hi Bobby;

The file doesn't create.

I create it and then I bring it 777 permissions.

But the file is empty...

Another option?

Thanks!

November 17, 2017 at 9:04 am #1433522

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

If you go to wpml.org/account/downloads/

you will see that you can select the filter for "beta" versions.

What are your results if you use the beta version of WPML and String Translation plugin ?

November 17, 2017 at 10:19 am #1433637

andoni larrañaga

Hi;

With Beta versions the same error on activate String Translation: 500

Error log continues empty

November 17, 2017 at 1:15 pm #1433903

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

Thank you,
Bobby

November 20, 2017 at 10:22 am #1435522

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details !

I have tried running the plugin duplicator to create a package to test your site locally.

Unfortunately this plugin as well causes an error 500 on your site which points me to believe this is related to your host server than WPML.

If possible please contact your host provider and make sure that your site's Memory is increased from their side as well too, as i can see you have increased your memory within wp-config.php but sometimes the Host needs to also increase it from their side too.

Let me know their response.

November 21, 2017 at 2:59 pm #1437125

andoni larrañaga

Hi;

In the Plesk panel the memory limit is set to 512M as well.
I increased timeout limits and other PHP params but still continues the error.

With all plugins deactivated, only active WPML MULTILINGUAL CMS and DUPLICATOR in depuration mode, it shows this error on every screen:
Notice: Undefined index: admin_notice in /var/www/vhosts/......./wp-content/plugins/sitepress-multilingual-cms/inc/icl-admin-notifier.php on line 370

Today other client, with diferent hosting, tell us with the same problem: suddenly error 500 on every pages. We must to disable STRING TRANSLATION plugin to page works again.

Now, we have 3 sites with same problem, 2 on same server and third one in another.

Thanks!!

November 21, 2017 at 4:09 pm #1437236

andoni larrañaga

Hi!

I found this threat about similar issue:
https://wpml.org/forums/topic/hi-since-last-wp-and-wpml-upgrade-i-had-blank-page-so-forced-to-downgrade/

So, I removed from wp_options table "icl_admin_messages" register.

After do that, I tried to activate "String Translation" plugin and I got this error:

Fatal error: Uncaught InvalidArgumentException: Translation name cannot be empty in /var/www/vhosts/*********/wp-content/plugins/wpml-string-translation/classes/filters/db-cache/class-wpml-st-page-translation.php:107 Stack trace: #0 /var/www/vhosts/*********/wp-content/plugins/wpml-string-translation/classes/filters/db-cache/class-wpml-st-page-translation.php(44): WPML_ST_Page_Translation->validate_values('29333', '', 'default') #1 /var/www/vhosts/*********/wp-content/plugins/wpml-string-translation/classes/filters/db-cache/persist/class-wpml-st-page-translations-persist.php(107): WPML_ST_Page_Translation->__construct('29333', '', 'default', '', false, '') #2 [internal function]: WPML_ST_Page_Translations_Persist->create_translation_from_db_record(Array) #3 /var/www/vhosts/*********/wp-content/plugins/wpml-string-translation/classes/filters/db-cache/persist/class-wpml-st-page-translations-persist.php(51): array_map(Array, Array) #4 /var/www/vhosts/******* in /var/www/vhosts/*********/wp-content/plugins/wpml-string-translation/classes/filters/db-cache/class-wpml-st-page-translation.php on line 107

So, I removed "29333" string from database and problem was solved.

I hope it helps you for other issues!

Then, I returned to stable versions of WPML again.

Thanks for your help.