This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.


This topic contains 4 replies, has 2 voices.

Last updated by bettyG 1 year ago.

Assigned support staff: Laura.

Author Posts
May 29, 2019 at 3:46 am #3911627


I'm trying to change the domain of my site from to
I'm using different domain per language.
The default language is French on
I changed the url on the WordPress settings and WPML settings. French is working fine so far.
But English is having an Error 500 for all the assets.
I didn't physically moved the files. Just changed the root folder for each domain. through the cPanel through the htaccess file.

May 29, 2019 at 3:22 pm #3916861


Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)


thanks for contacting us.

We need to see exactly the error, so please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

Browse to the page with the issue and/or reproduce the issue.

Locate the debug log in: /wp-content/debug.log

Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

May 30, 2019 at 1:54 pm #3923517



May 30, 2019 at 1:56 pm #3923529


I found the problem. In the htaccess file, I had kept some of the old code that was creating a conflict with the new root folder code. Removing the old code fixed everything.

May 30, 2019 at 1:57 pm #3923533


My issue is resolved now. Thank you!