Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem:
Cannot activate WPML and I am getting this error:

WPML is missing some records in the languages tables and it cannot fully work until this issue is fixed.

Please go to the Troubleshooting page and click on "Clear language information and repopulate languages" to fix this problem.

Solution:
Solution here: https://wpml.org/forums/topic/error-activating-wpml-multilingual-cms/#post-4030653

0% of people find this useful.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 3 voices.

Last updated by Noman 5 months ago.

Assigned support staff: Noman.

Author Posts
June 11, 2019 at 10:48 am #3994301

daneelM

Hello!
I am having a bit of bother activating WPML. I had it installed previously but decided to delete it and work on the translation later. I am now trying to set it up, however, I am worried that I may have messed something up initially and is causing trouble now.

I am getting the error:

WPML is missing some records in the languages tables and it cannot fully work until this issue is fixed.

Please go to the Troubleshooting page and click on "Clear language information and repopulate languages" to fix this problem.

Firstly, I kept getting "cannot access this page" and used the solution here (https://wpml.org/forums/topic/wpml-sorry-you-are-not-allowed-to-access-this-page/) by adding this code snippet:

function wpmlsupp_1706_reset_wpml_capabilities() {
    if ( function_exists( 'icl_enable_capabilities' ) ) {
        icl_enable_capabilities();
    }
}
add_action( 'shutdown', 'wpmlsupp_1706_reset_wpml_capabilities' );

This got me through, and I used the "Clear language information and repopulate languages"
After trying this, it didn't seem to resolve anything (the error still appears at the top) and now the option does not appear in the Troubleshooting page. (Screenshot attached)

I then proceeded to use this solution (https://wpml.org/forums/topic/cannot-install-icl_languages-doesnt-exist-for-query/) and deleted the icl_sitepress_settings.
This started the WPML setup again but did not resolve the issue.

I have also tried the "reset" option and that doesn't solve the issue either.

And, have also tried Reset PRO translation configuration found here (https://wpml.org/forums/topic/how-to-reset-the-wpml-plugin/).

I noticed errors coming up on the frontend (Screenshot attached) and used the solution here (https://wpml.org/forums/topic/warning-illegal-offset-type-in-isset-or-empty-in-6/) by removing warnings.

Pretty much everything is a mess. Is there a way I can completely delete everything and start anew?

Any help or information would be much appreciated and don’t hesitate if you need more information.

Thanks,

Daneel

June 11, 2019 at 11:02 am #3994429

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

=== Please backup your database and website ===

2. Please upgrade your server’s MySQL version to a higher level: https://wpml.org/home/minimum-requirements/
MySQL 5.5.5 version in your site, is lower than the required for WPML.

3. You are using an older version of WordPress on your site, please backup your site and update WordPress to it’s latest version 5.2.1.

4. If you have just installed plugin and configuring WPML first time on this site and do not have any translated data yet then you can fix this issue by removing WPML and all its data completely from database, To do so, please go to WPML >> Support >> Troubleshooting (the link is at the bottom of the support page). >> There, click on “Reset and deactivate WPML” >> then Delete the plugin.

- After deleting all WPML data and WPML related plugins then please install WPML plugins again and I hope now you will not face any issue.

This issue usually happens due to some corruption in the database, if you are installing WPML first time in this site and you see some database tables starting with <srtong>icl_</srtong> even after reset, please also delete those tables and try reinstalling WPML.

Here is doc for more details:
https://wpml.org/faq/how-wpml-reset-works/

5. Please delete all sort of caches on your site / server cache / plugin cache (WP Super Cache) / CDN cache (if any), clear browser cache and then check the page. I would suggest to disable WP Super Cache plugin temporary.

6. If still issue persists, please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

June 12, 2019 at 12:34 pm #4004279

daneelM

Hello!

Thanks for the response.

I have carried out the steps:

- Increased memory limit
- My hosting is currently running 10.3.15-MariaDB (cannot change due to being on shared server)
- Upgraded WP
- Deactivated cache
- I "reset and deactivated" and deleted WPML and all related plugins.

However, I am still getting the same issue.

Upon re-uploading, installing and activating CMS I am presented with the same error. (screenshot attached). Upon "clear language and repopulate languages" it notifies as "done" however, the error persists.

Upon configuring WPML I noticed there are no flag icons for language selection and did not register any menus (for switcher). Carrying onward, it changed the homepage to the 404 page, the menu was broken and all my "pages" were non-existent. (screenshot attached)

I have reset, deactivated and deleted again and the site is back to normal.

I am using Oxygen therefore do not have a theme installed and have had WPML and all its components previously installed correctly on this before.

Any help would be greatly appreciated.

Thanks,

Daneel

June 12, 2019 at 4:03 pm #4005971

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

To further debug this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

June 16, 2019 at 1:07 pm #4030529

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thanks for login details. My off days are Friday and Saturday and now I am available and working on this issue and will update you with findings soon.

Thank you

June 16, 2019 at 2:21 pm #4030653

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have followed the below steps in order to fix this issue.
- Enabled error reporting in your site by adding below code in wp-config.php file:

 // Enable WP_DEBUG mode
define( 'WP_DEBUG', true );

// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );

// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

- Went to WPML >> Support >> Troubleshooting (the link is at the bottom of the support page). >> There, clicked on “Reset and deactivate WPML” >> then Deleted the plugin.

- Activated WP default theme e.g. twentyseventeen.

- Then deactivated all plugins and installed/activated WPML plugins and finished configuration steps. I temporarily selected "English" as default and "French" as the secondary language to get this going for you. This can be changed by going to WPML >> Languages >> Site Languages. There are two buttons: "Change default language" and "Add/Remove languages".

- Then activated previous activated theme and plugins.

Now WPML working fine, could you please check and confirm?

Thank you

June 25, 2019 at 9:20 am #4082651

daneelM

My issue is resolved now. Thank you!

April 26, 2020 at 4:49 am #5994925

khaledS-6

I have a problem to activate the WPML plugin in my website, please I need help

This is a screenshot for the problem

hidden link

and This information allows our support team to see the versions of WordPress, plugins and theme on your site. Provide this information if requested in our support forum. No passwords or other confidential information is included.

{"core":{"Wordpress":{"Multisite":"No","SiteURL":"https:\/\/baitalritag.com","HomeURL":"https:\/\/baitalritag.com","Version":"5.4","PermalinkStructure":"\/%postname%\/","PostTypes":"post, page, attachment, revision, nav_menu_item, custom_css, customize_changeset, oembed_cache, user_request, wp_block, wpforms, elementor_library, wpforms_log, dt_portfolio, dt_gallery, dt_team, dt_testimonials, dt_slideshow, wpcf7_contact_form, elementor_font, elementor_icons","PostStatus":"publish, future, draft, pending, private, trash, auto-draft, inherit, request-pending, request-confirmed, request-failed, request-completed","RestEnabled":"Yes"},"Server":{"jQueryVersion":"1.12.4-wp","PHPVersion":"7.3.16","MySQLVersion":"5.7.25","ServerSoftware":"Apache"},"PHP":{"MemoryLimit":"768M","WP Memory Limit":"256M","UploadMax":"128M","PostMax":"128M","TimeLimit":"120","MaxInputVars":"3000","MBString":true,"libxml":true}},"plugins":{"active_plugins":{"sitepress-multilingual-cms\/sitepress.php":{"Plugin Slug":"sitepress-multilingual-cms","Name":"WPML Multilingual CMS","PluginURI":"https:\/\/wpml.org\/","Version":"4.3.12","Author":"OnTheGoSystems","AuthorURI":"http:\/\/www.onthegosystems.com\/","TextDomain":"sitepress-multilingual-cms","DomainPath":"","Network":false,"RequiresWP":"","RequiresPHP":"","Title":"WPML Multilingual CMS","AuthorName":"OnTheGoSystems"},"LayerSlider\/layerslider.php":{"Plugin Slug":"","Name":"The7 LayerSlider WP","PluginURI":"https:\/\/layerslider.kreaturamedia.com","Version":"6.10.2","Author":"Kreatura Media","AuthorURI":"https:\/\/kreaturamedia.com","TextDomain":"LayerSlider","DomainPath":"","Network":false,"RequiresWP":"","RequiresPHP":"","Title":"The7 LayerSlider WP","AuthorName":"Kreatura Media"},"contact-form-7-mailchimp-extension\/cf7-mch-ext.php":{"Plugin Slug":"","Name":"Contact Form 7 Extension For Mailchimp","PluginURI":"http:\/\/renzojohnson.com\/contributions\/contact-form-7-mailchimp-extension","Version":"0.5.17","Author":"Renzo Johnson","AuthorURI":"http:\/\/renzojohnson.com","TextDomain":"contact-form-7","DomainPath":"\/languages\/","Network":false,"RequiresWP":"","RequiresPHP":"","Title":"Contact Form 7 Extension For Mailchimp","AuthorName":"Renzo Johnson"},"contact-form-7\/wp-contact-form-7.php":{"Plugin Slug":"","Name":"Contact Form 7","PluginURI":"https:\/\/contactform7.com\/","Version":"5.1.7","Author":"Takayuki Miyoshi","AuthorURI":"https:\/\/ideasilo.wordpress.com\/","TextDomain":"contact-form-7","DomainPath":"\/languages\/","Network":false,"RequiresWP":"","RequiresPHP":"","Title":"Contact Form 7","AuthorName":"Takayuki Miyoshi"},"dt-the7-core\/dt-the7-core.php":{"Plugin Slug":"","Name":"The7 Elements","PluginURI":"","Version":"2.4.0","Author":"Dream-Theme","AuthorURI":"http:\/\/dream-theme.com\/","TextDomain":"dt-the7-core","DomainPath":"\/languages","Network":false,"RequiresWP":"","RequiresPHP":"","Title":"The7 Elements","AuthorName":"Dream-Theme"},"easy-theme-and-plugin-upgrades\/init.php":{"Plugin Slug":"","Name":"Easy Theme and Plugin Upgrades","PluginURI":"http:\/\/wordpress.org\/extend\/plugins\/easy-theme-and-plugin-upgrades\/","Version":"2.0.1","Author":"Chris Jean","AuthorURI":"https:\/\/chrisjean.com\/","TextDomain":"easy-theme-and-plugin-upgrades","DomainPath":"","Network":false,"RequiresWP":"","RequiresPHP":"","Title":"Easy Theme and Plugin Upgrades","AuthorName":"Chris Jean"},"elementor-pro\/elementor-pro.php":{"Plugin Slug":"","Name":"Elementor Pro","PluginURI":"https:\/\/elementor.com\/","Version":"2.9.3","Author":"Elementor.com","AuthorURI":"https:\/\/elementor.com\/","TextDomain":"elementor-pro","DomainPath":"","Network":false,"RequiresWP":"","RequiresPHP":"","Title":"Elementor Pro","AuthorName":"Elementor.com"},"elementor\/elementor.php":{"Plugin Slug":"","Name":"Elementor","PluginURI":"https:\/\/elementor.com\/?utm_source=wp-plugins\u0026utm_campaign=plugin-uri\u0026utm_medium=wp-dash","Version":"2.9.8","Author":"Elementor.com","AuthorURI":"https:\/\/elementor.com\/?utm_source=wp-plugins\u0026utm_campaign=author-uri\u0026utm_medium=wp-dash","TextDomain":"elementor","DomainPath":"","Network":false,"RequiresWP":"","RequiresPHP":"","Title":"Elementor","AuthorName":"Elementor.com"},"essential-grid\/essential-grid.php":{"Plugin Slug":"","Name":"Essential Grid","PluginURI":"https:\/\/essential.themepunch.com","Version":"2.3.5","Author":"ThemePunch","AuthorURI":"https:\/\/themepunch.com","TextDomain":"essential-grid","DomainPath":"\/languages","Network":false,"RequiresWP":"","RequiresPHP":"","Title":"Essential Grid","AuthorName":"ThemePunch"},"revslider\/revslider.php":{"Plugin Slug":"","Name":"The7 Slider Revolution","PluginURI":"https:\/\/revolution.themepunch.com\/","Version":"6.2.2","Author":"ThemePunch","AuthorURI":"https:\/\/themepunch.com\/","TextDomain":"revslider","DomainPath":"\/languages","Network":false,"RequiresWP":"","RequiresPHP":"","Title":"The7 Slider Revolution","AuthorName":"ThemePunch"},"sg-cachepress\/sg-cachepress.php":{"Plugin Slug":"","Name":"SG Optimizer","PluginURI":"https:\/\/siteground.com","Version":"5.4.6","Author":"SiteGround","AuthorURI":"https:\/\/www.siteground.com","TextDomain":"sg-cachepress","DomainPath":"\/languages","Network":false,"RequiresWP":"","RequiresPHP":"","Title":"SG Optimizer","AuthorName":"SiteGround"},"svg-support\/svg-support.php":{"Plugin Slug":"","Name":"SVG Support","PluginURI":"http:\/\/wordpress.org\/plugins\/svg-support\/","Version":"2.3.18","Author":"Benbodhi","AuthorURI":"https:\/\/benbodhi.com","TextDomain":"svg-support","DomainPath":"\/languages","Network":false,"RequiresWP":"","RequiresPHP":"","Title":"SVG Support","AuthorName":"Benbodhi"},"updraftplus\/updraftplus.php":{"Plugin Slug":"","Name":"UpdraftPlus - Backup\/Restore","PluginURI":"https:\/\/updraftplus.com","Version":"2.16.23.0","Author":"UpdraftPlus.Com, DavidAnderson","AuthorURI":"https:\/\/updraftplus.com","TextDomain":"updraftplus","DomainPath":"\/languages","Network":false,"RequiresWP":"","RequiresPHP":"","Title":"UpdraftPlus - Backup\/Restore","AuthorName":"UpdraftPlus.Com, DavidAnderson"},"wpforms-mailchimp\/wpforms-mailchimp.php":{"Plugin Slug":"","Name":"WPForms MailChimp","PluginURI":"https:\/\/wpforms.com","Version":"1.3.0","Author":"WPForms","AuthorURI":"https:\/\/wpforms.com","TextDomain":"wpforms-mailchimp","DomainPath":"languages","Network":false,"RequiresWP":"","RequiresPHP":"","Title":"WPForms MailChimp","AuthorName":"WPForms"},"wpforms\/wpforms.php":{"Plugin Slug":"","Name":"WPForms","PluginURI":"https:\/\/wpforms.com","Version":"1.5.9.4","Author":"WPForms","AuthorURI":"https:\/\/wpforms.com","TextDomain":"wpforms-lite","DomainPath":"languages","Network":false,"RequiresWP":"","RequiresPHP":"","Title":"WPForms","AuthorName":"WPForms"},"wpml-media-translation\/plugin.php":{"Plugin Slug":"wpml-media-translation","Name":"WPML Media","PluginURI":"https:\/\/wpml.org\/","Version":"2.5.5","Author":"OnTheGoSystems","AuthorURI":"http:\/\/www.onthegosystems.com\/","TextDomain":"wpml-media-translation","DomainPath":"","Network":false,"RequiresWP":"","RequiresPHP":"","Title":"WPML Media","AuthorName":"OnTheGoSystems"},"wpml-string-translation\/plugin.php":{"Plugin Slug":"wpml-string-translation","Name":"WPML String Translation","PluginURI":"https:\/\/wpml.org\/","Version":"3.0.9","Author":"OnTheGoSystems","AuthorURI":"http:\/\/www.onthegosystems.com\/","TextDomain":"wpml-string-translation","DomainPath":"","Network":false,"RequiresWP":"","RequiresPHP":"","Title":"WPML String Translation","AuthorName":"OnTheGoSystems"},"wpml-translation-management\/plugin.php":{"Plugin Slug":"wpml-translation-management","Name":"WPML Translation Management","PluginURI":"https:\/\/wpml.org\/","Version":"2.9.6","Author":"OnTheGoSystems","AuthorURI":"http:\/\/www.onthegosystems.com\/","TextDomain":"wpml-translation-management","DomainPath":"","Network":false,"RequiresWP":"","RequiresPHP":"","Title":"WPML Translation Management","AuthorName":"OnTheGoSystems"}},"mu_plugins":[],"dropins":{"object-cache.php":{"Plugin Slug":"","Name":"Memcached","PluginURI":"","Version":"1.0.0","Description":"Memcached Dropin for SGO","Author":"","AuthorURI":"","TextDomain":"","DomainPath":"","Network":false,"RequiresWP":"","RequiresPHP":"","Title":"Memcached","AuthorName":""}}},"theme":{"Name":"The7","ThemeURI":false,"Author":"Dream-Theme","AuthorURI":"http:\/\/dream-theme.com\/","Template":"","Version":"8.7.0","TextDomain":"the7mk2","DomainPath":"","ParentName":""},"extra-debug":{"installer":{"version":"2.3.0","repositories":{"wpml":{"api-url":"https:\/\/api.wpml.org\/","bucket-url":"https:\/\/wpmlorg.s3.amazonaws.com\/wpml-bucket-22.json","subscription":{"key":"bHw3l3S1j6","data":{"subscription_type":6719,"expires":"2020-12-09","status":"1","notes":""},"registered_by":1,"site_url":"https:\/\/baitalritag.com"}},"toolset":{"api-url":"https:\/\/api.toolset.com\/","bucket-url":"not assigned","subscription":""}},"instances":{"\/home\/customer\/www\/baitalritag.com\/public_html\/wp-content\/plugins\/sitepress-multilingual-cms\/vendor\/otgs\/installer\/installer.php":{"bootfile":"\/home\/customer\/www\/baitalritag.com\/public_html\/wp-content\/plugins\/sitepress-multilingual-cms\/vendor\/otgs\/installer\/installer.php","version":"2.3.0","args":{"plugins_install_tab":1,"site_key_nags":[{"repository_id":"wpml","product_name":"WPML","condition_cb":[{"locale_utils":{},"footer_preview":false,"icl_translations_cache":null,"icl_language_name_cache":{},"icl_term_taxonomy_cache":null,"wpdb":{"show_errors":false,"suppress_errors":false,"last_error":"","num_queries":43,"num_rows":0,"rows_affected":0,"insert_id":0,"last_query":"SELECT autoload FROM kjd_options WHERE option_name = \u0027the7_auto_deactivated\u0027","last_result":[],"queries":null,"prefix":"kjd_","base_prefix":"kjd_","ready":true,"blogid":0,"siteid":0,"tables":["posts","comments","links","options","postmeta","terms","term_taxonomy","term_relationships","termmeta","commentmeta","actionscheduler_actions","actionscheduler_claims","actionscheduler_groups","actionscheduler_logs"],"old_tables":["categories","post2cat","link2cat"],"global_tables":["users","usermeta"],"ms_global_tables":["blogs","blogmeta","signups","site","sitemeta","sitecategories","registration_log"],"comments":"kjd_comments","commentmeta":"kjd_commentmeta","links":"kjd_links","options":"kjd_options","postmeta":"kjd_postmeta","posts":"kjd_posts","terms":"kjd_terms","term_relationships":"kjd_term_relationships","term_taxonomy":"kjd_term_taxonomy","termmeta":"kjd_termmeta","usermeta":"kjd_usermeta","users":"kjd_users","blogs":null,"blogmeta":null,"registration_log":null,"signups":null,"site":null,"sitecategories":null,"sitemeta":null,"field_types":{"post_author":"%d","post_parent":"%d","menu_order":"%d","term_id":"%d","term_group":"%d","term_taxonomy_id":"%d","parent":"%d","count":"%d","object_id":"%d","term_order":"%d","ID":"%d","comment_ID":"%d","comment_post_ID":"%d","comment_parent":"%d","user_id":"%d","link_id":"%d","link_owner":"%d","link_rating":"%d","option_id":"%d","blog_id":"%d","meta_id":"%d","post_id":"%d","user_status":"%d","umeta_id":"%d","comment_karma":"%d","comment_count":"%d","active":"%d","cat_id":"%d","deleted":"%d","lang_id":"%d","mature":"%d","public":"%d","site_id":"%d","spam":"%d"},"charset":"utf8mb4","collate":"utf8mb4_unicode_520_ci","func_call":"$db-\u003Equery(\u0022SELECT autoload FROM kjd_options WHERE option_name = \u0027the7_auto_deactivated\u0027\u0022)","is_mysql":true,"categories":"kjd_categories","post2cat":"kjd_post2cat","link2cat":"kjd_link2cat","actionscheduler_actions":"kjd_actionscheduler_actions","actionscheduler_claims":"kjd_actionscheduler_claims","actionscheduler_groups":"kjd_actionscheduler_groups","actionscheduler_logs":"kjd_actionscheduler_logs"}},"setup"]}]},"delegated":true}}}}}

April 26, 2020 at 10:57 am #5995703

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

@khaleds-6 This ticket was closed. We will help you on the new ticket that you have created now.

Thanks