This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 21 replies, has 3 voices.

Last updated by Alejandro 7 months ago.

Assigned support staff: Alejandro.

Author Posts
December 12, 2018 at 3:29 pm #2994136

davidG-36

Hello,

I'm using simple translate editor for translate from English to Polish (via duplicate and translate independently then).

After I go from the English page to the newly duplicated Polish page using language switcher(from dashboard), plugin redirects me to the Create new page, where it shows the message:
'WPML will copy min_price, post_sidebar_pos, post_views_count, rate_review, _wpml_media_duplicate, _wpml_media_featured from English when you save this post.'

As I know it must redirect me to the duplicated Polish page directly, as it worked previously.
I noticed this error yesterday, after I update WPML to the last version.

December 12, 2018 at 5:46 pm #2994600

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would need to replicate the same steps you made in your WordPress Dashboard in order to understand the real cause of this issue, so I would ask you to tell me into details the steps need to reproduce it, including the page you tied that and some access for your WordPress Dashboard, for that please, consider:

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

December 13, 2018 at 1:36 pm #2997938

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I could make the duplicated content appears in the secondary language pages with this workflow:

1 - In your WordPress Dashboard > WPML > Settings > How to translate posts and pages settings choose the option 'Create translations manually'.

2 - In your WordPress Dashboard > Pages click to duplicate a page, instead of changing directly to a secondary laguage, click the pencil icon from the language box of your page editing screen, so the translation/duplication information can be properly setup for your post.

You can read more information of the duplication feature at: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/

Please, let me know if you need any additional clarifications. Have a nice day.

December 14, 2018 at 7:09 am #3000740

davidG-36

On the main website I already use the option 'Create translations manually', but I have this error anyway.

In wordpress Dashboard > Pages I click to duplicate a page and only after that I try to to directly to a secondary language using its flag. I know, that I can use the pencil icon from the language box, but using the flags is more easy for my customers.

The true is, that in previous versions of WPML, I was able to go to the duplicated content directly via secondary language's flags and now I can't because it redirects me to the 'Create new page'.

So, it means, you have no solution for this issue.
The question is, it's temporary or permanent 🙂

December 14, 2018 at 6:52 pm #3002842

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I just tried your workflow in my local minimal installation and it worked as you described it worked for you before. I would like to perform some detailed tests using a copy of your website, so we can confirm the reason it stopped workiing for your particular case, for that, please, consider:

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.
Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.I will also need the username and password of an account that was created BEFORE creating the duplicator package.I will enable the next reply to be private so only you and I have access to it!

Thank you for your collaboration. Have a nice day.

December 18, 2018 at 4:35 pm #3013116

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the details provided and sorry for the the waiting here. I took an extensive test in my local installation using your provided package and could indeed confirm this issue, when using a previous version of the WPML plugin, we have the same behavior described by you, when uing the most recent version, it would be needed to click the pencil icon or hit the update button before being able to redirect to the duplicated page using the language switcher in the WordPress admin bar.

I will now proceed with some reports for our coleagues in order to confirm if they see the same issue and finally a report to the dev team will be made, I will update you regarding any details I get. Thank you for the report and your patience while waiting for a fix. Have a nice day.

December 18, 2018 at 8:28 pm #3013747

davidG-36

Thank you for your answer, but I should note once again, that when I used the previous version of the WPML plugin, I did not have the problem described.

I remember it exactly.
Have a nice day.

December 20, 2018 at 12:49 pm #3020722

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates and sorry for the bit of waiting. I took a look in the current development logs and there's an issue which might be related to this one and probably the cause of this issue too, it is now fixed to be released in the next update version, I don't know exactly when it will be relased, but it should happen soon.

As soon as you see the notice to update the WPML Multilingual CMS plugin, upgrade it and please let me know if you still see the same issue, so we can look for further alternatives. Thank you for your collaboration, have a nice day.

December 23, 2018 at 8:41 pm #3029181

davidG-36

Hello,

I see the notice to update the WPML Multilingual CMS plugin and WPML Translation Management add-on.

Is this what we were waiting for?

December 24, 2018 at 5:14 pm #3031162

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Please, update it and let me know if it fixes the issue on your side.

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

Have a nice day.

December 24, 2018 at 6:20 pm #3031203

davidG-36

Hello,

Thanks for your reply.
Updated. The problem still persists.

December 28, 2018 at 9:44 am #3039613

davidG-36

I still need assistance.

December 28, 2018 at 4:47 pm #3040878

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, my name is Alejandro.

Since Marcos currently has a few days off, I will replace him here in the forum.
I hope this is OK with you.

❌ Before proceeding please make a full website backup! ❌
Go to WPML -> Support -> Troubleshooting
Press the following buttons:
• "Clear the cache in WPML"
• "Remove ghost entries from the translation tables"
• "Fix element_type collation"
• "Set language information"
• "Fix post type assignment for translations"
• "Recreate String Cache Database Table"
Please check if the issue is fixed after every button press.

Let me know how this goes and if any of the steps helped you fix this.

December 29, 2018 at 4:43 pm #3042441

davidG-36

Hello Alejandro,

Thank you for your reply.

I tried all you wrote and exactly like you wrote.
None of these steps helped me solve this problem.
In the end, I even cleared the entire cache on my server.

January 2, 2019 at 11:09 am #3048676

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I managed to replicate this problem on a clean install and i sent it to our developers for further testing, i'll update you once i get an answer from them.

Regards,
Alejandro.