This thread is resolved. Here is a description of the problem and solution.

Problem: Add to cart button and variation does not appear in the product.

Solution: - Update WPML and WooCommerce to the latest version - Set correct translating preferences for product_type, product_variation and product_visibility. - Sync product_type from WooCommerce> Status > Troubleshooting - Disable WooCommerce > WooCommerce Multilingual > Multi-Currency: Show only products with custom prices in secondary currencies then save.

Relevant Documentation: https://wpml.org/documentation/related-projects/woocommerce-multilingual/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 3 voices.

Last updated by ahmedS-44 1 week, 4 days ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
May 24, 2020 at 7:09 pm #6205503

ahmedS-44

ERROR: all Products from all languages show on shop page in other language ,
my site is Arabic as main language it's right and shop page show Show product Arabic BUT have error in count product
-----------------------------
anther language is English shop page appear all product from English and Arabic also
i need know how i can fixed it , how can appear Arabic product only in shop page Arabic , and English product appear only in English shop page

hidden link

May 26, 2020 at 9:27 am #6217453

ahmedS-44

I still wait reply from 2 days ago

May 26, 2020 at 10:10 am #6217781

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

While you are waiting for one of my colleagues to take this ticket and work on it, let me provide you with first debugging steps or if I can perhaps help with the issue quickly.

Does it happen if you try switching the theme?

If it is not happening there when you switch the theme, then it is possible that your current theme loop requires to be updated with the suppress_filters set to false:
https://wpml.org/forums/topic/get_posts-with-suppress_filters-false-stillreturns-posts-in-all-languages/#post-1099912
https://developer.wordpress.org/reference/functions/get_posts/#parameters

Regards,
Bruno Kos

May 27, 2020 at 9:55 pm #6233395

ahmedS-44

my web site two language, website start up arabic language in this langugh all thing right and product appear right and from product under arabic langugh only
BUT when switch to english language Shop Page appear all product from arabic and english

May 28, 2020 at 6:46 am #6236081

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

1) Can you please test the step Bruno suggested before?

2) Are these products translated correctly? You need to send products for translation and translate all into English. Since I can see in page source it is showing English product but it is in Arabic. So either it was not translated or it was translated but not correctly.

Go to the WooCommerce -> WooCommerce Multilingual page, you will start on the Products tab.

Do all products have a pencil or a plus icon? Click on the Pen icon to edit existing product translations or the Plus icon to translate the product.

Please check: https://wpml.org/documentation/related-projects/woocommerce-multilingual/#products

3) Are you sure you have not enabled "Displaying Untranslated Content on Pages in Secondary Languages"? This will show Arabic products on the English page if translation doesn't exist.

Info: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/

Let me know how it goes.

Thanks and regards.
Drazen

June 1, 2020 at 11:33 am #6264987

ahmedS-44

Thanks
i have anther problem , add to cart button and variation select box NOT appear in product
page , please check link below , In spite of i have stock

hidden link

June 2, 2020 at 6:20 am #6270361

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

are all attributes and variations translated to 2nd language?

1) Go to the WooCommerce -> WooCommerce Multilingual page > Attributes > Choose Attributes in question.

2) Check if they all have pencil icon (translated) otherwise translate them

3) After translation of attributes is done, the related variations of the products in other languages need to be created as well. This is done by using the Synchronize attributes and update the product variations button located at the bottom of this page.

Info:
- https://wpml.org/documentation/related-projects/woocommerce-multilingual/#taxonomies
- https://wpml.org/documentation/related-projects/woocommerce-multilingual/#variations

Please check and let me know.

Thanks,
Drazen

June 3, 2020 at 12:05 am #6277795

ahmedS-44

i do
1) Go to the WooCommerce -> WooCommerce Multilingual page > Attributes > Choose Attributes in question.

2) Check if they all have pencil icon (translated) otherwise translate them

BUT still Have same problem NOt vairation or price appaer in product page
plaese Check link Below
hidden link

will found This product is currently out of stock and unavailable. message In spite of i have stock and price

June 3, 2020 at 6:53 am #6279931

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

In order to investigate this issue and to understand it better, I would need to access your website.

Please make a full backup of your site (files and database) and confirm it in your next reply. I might need to enable/disable plugins, switch themes and access your website database.

I would need to access both your site's wp-admin and FTP account. Be sure to provide both.

I have enabled the private username and password fields in your next reply.

I suggest you create a temporary user, set it as an administrator and then add those credentials in the private fields mentioned.

You can safely add your information into these fields.

Thanks,
Drazen

June 3, 2020 at 8:08 pm #6286881

ahmedS-44

i notes when i stop (wpml-translation-management ) , all thing back right and site appear right ,and product page appear right !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!1

June 4, 2020 at 9:28 am #6291707

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

1) in order to be able to help you out, I need to see and check the issue.

I can check by accessing your website as described in my previous reply or you can share with me a Duplicator copy of your website.

Info: https://wpml.org/faq/provide-supporters-copy-site/

2)

i notes when i stop (wpml-translation-management ) , all thing back right and site appear right ,and product page appear right

You will need to use a Translation management addon in order for WooCommerce to work correctly with WPML and WooCommerce Multilingual addon.

Make sure all products, attributes, and variations are translated 100%.

Let me know how you want to proceed and how can I check the issue.

Thanks,
Drazen

June 5, 2020 at 11:16 am #6304119

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

I have managed to fix the issue. You had a few issues and feature activated that caused this issue. Some settings from WPMl>Settings> Custom Post Type / Custom Fields were changed to don't translate.

What have I done:
- update WPML and WooCommerce to the latest version
- Set correct translating preferences for product_type, product_variation and product_visibility.
- Checked settings for all Custom fields and Custom terms
- Synced product_type from WooCommerce> Status > Troubleshooting
- Disabled WooCommerce > WooCommerce Multilingual > Multi-Currency: Show only products with custom prices in secondary currencies then save.

Please check the image attached.

Please let me know if there is anything else I can do for you.

Regards,
Drazen

July 3, 2020 at 7:16 pm #6516587
ahmedS-44

Ok Now peoduct appear right with price and add to basket button
BUT i have problem when (wpml-translation-management, wpml-string-translation) active website become very slow and and Physical Memory Usage on server become 100%

New threads created by Dražen Duvnjak and linked to this one are listed below:

https://wpml.org/forums/topic/split-usage-on-server-become-100/

July 3, 2020 at 7:30 pm #6516597

ahmedS-44

serevr become very slow and server statistic will be
Physical Memory Usage
1 GB / 1 GB (100%)
I/O Usage
1 MB/s / 1 MB/s (100%)

July 13, 2020 at 11:36 pm #6587271

ahmedS-44

serevr become very slow and server statistic will be
Physical Memory Usage
1 GB / 1 GB (100%)
I/O Usage
1 MB/s / 1 MB/s (100%)