This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 26 replies, has 2 voices.

Last updated by Shekhar Bhandari 4 months, 3 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 9, 2019 at 5:48 am #3773207

michaelG-87

I am trying to: do a translationen but I got the classical editor

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

Error: Api error missing resource: Website not found, please validate site identifier

May 9, 2019 at 5:55 am #3773219

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thanks for getting in touch, I can definitely help you out with this.

It seems you are trying to use Advanced Translation Editor and having this issue, right? Most of the time this issue appears due to key conflicts in DB, so to fix the issue, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to receiving your answers so we can get to the bottom of this issue.

Thanks

May 17, 2019 at 8:46 am #3832469

michaelG-87

Can you send me a fix that I can do myself

May 22, 2019 at 11:06 am #3864623

michaelG-87

Hi Shekhar,

i run a managed wordpress site. The hoster does not support individual plugins. Therefore, I cannot access phpmyadmin.

My problem is still unsolved. Do you have another option?

May 23, 2019 at 3:21 am #3870809

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I think you should contact the host and ask if there is any way to access the phpmyadmin, I believe they should have some ways to either use phpmyadmin or allow access to edit the database.

Let me know how it goes.

Thanks

May 23, 2019 at 8:18 am #3872459

michaelG-87

Sorry shekhar, no chance! Any other solutions - new installation?

May 23, 2019 at 12:10 pm #3874915

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

If you have ftp details you can use the adminer.php file from here and make changes in the database hidden link.

Let me know if this helps.

Thanks

May 23, 2019 at 12:22 pm #3874947

michaelG-87

Hi Shekhar, thanks a lot. So, if I send you the ftp access you can fix it as mentioned in your mail 9. May? Can you send me a private link ?

May 23, 2019 at 12:25 pm #3874957

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Sure, I have enabled the private reply for you.

Thanks

May 24, 2019 at 4:04 am #3880997

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The login detail is not working, so could you please check the login details and provide the correct details.

You can edit the previous private reply and send the updated details.

Look forward to your reply.

Thanks

May 24, 2019 at 5:51 am #3881293

michaelG-87

I updated the information

May 24, 2019 at 6:09 am #3881323

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The ftp details don't have write permission, so I couldn't upload the adminer file for fixing the issue, I recently noticed an alternative way so could you please follow the below steps:

- Backup your site
- Go to hidden link
- Change the options as I mentioned here: https://wpml.org/forums/topic/error-api-error-missing-resource-website-not-found-please-validate-site-ident-2/#post-3833433

Let me know if this helps.

Thanks

May 24, 2019 at 6:19 am #3881375

michaelG-87

I went to options.php... I updated the private message to you with information about this.
Can you please send me a private message with the relevant information. thank you

May 24, 2019 at 6:21 am #3881383

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

As mentioned here: https://wpml.org/forums/topic/error-api-error-missing-resource-website-not-found-please-validate-site-ident-2/#post-3833433

Replace the wpml_site_id:ate with the WPML_SITE_ID:global

- Now go to WPML->Settings and try to synchronize the translators, the issue should be solved.

Let me know if this helps.

Thanks

May 24, 2019 at 6:30 am #3881481

michaelG-87

I replaced the information from global and pasted them in ate. Then i tried to sync. -> Failed!

The topic ‘[Closed] Error: Api error missing resource: Website not found, please validate site ident’ is closed to new replies.