If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Andreas W. 2 months, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
September 2, 2019 at 3:14 pm

rubenC-21

I am trying to:

Create with Sensei One Course in English and their translations in Spanish. The user will have access to this course via membership sold with WooCommerce Membership.

Link to a page where the issue can be seen, login as Administrator not even as Customer:
- hidden link (Original Language)
- hidden link (Translated Language)

In case you want to login as Customer:

In case of using SFTP. please use port 2222
Thank you.

September 2, 2019 at 5:13 pm #4499373

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

The issue has already been escalated to our compatibility team and we are working on a solution.

The issue seems to be that the post type slugs which can be found at WPML -> Settings -> Post Type Translation -> Courses can not be translated or WPML does not recognize the translated courses.

We are about to investigate what is causing the issue and will be in contact as soon we can provide a workaround.

Kind regards
Andreas

September 5, 2019 at 4:51 am #4515435

rubenC-21

Is there any status about this workaround?
Thank you!

September 5, 2019 at 7:42 pm #4521905

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

As far we been investigationg there are two possible workarounds:

So one solution would be to just make the site's default language to English. That way you don't have to worry about the URL parameter.

If you do not have English as your site's default language or as a language at all, you will need to change the URL format from Parameter to Directories, resave the permalink and then at most, update the course and its translation and that will allow you to translate the slug of that post type (through String Translation though) correctly.

Let me know if you do have any questions regarding those workarounds. I will be in contact as soon I will receive more feedback.

Kind regards
Andreas

September 6, 2019 at 3:08 pm #4526215

rubenC-21

Hi Andreas, so far this workarounds doesn't work.

Another way to describe this issue is for example: If I'm in the WordPress admin and go to Courses, if I click in "view" any of the courses (and languages), it is showing 404 error anyway.

What else it could be?
I'm tried already disable all plugins except Sensei, WMPL and WooCommerce and I switch to Twenty Nineteen theme, but the outcome is the same.

Any other ideas?
Thank you

September 6, 2019 at 4:23 pm #4526695

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I can see you followed the workaround but the Courses were not translated yet.

It is actually working now:

hidden link

hidden link

Please now also make sure to translate the lessons and let me know if it worked out.

I will keep you updated once I receive more feedback from our compatiblity team.

Kind regards
Andreas

September 6, 2019 at 4:38 pm #4526805

rubenC-21

Thanks Andres for look into this, but they are not working again.
As soon as I clear the caches everything crashes again.

Also, because all this issues, I'm not translating the courses itself.

As an other option this issue, I'm creating two isolated curses with their lessons per each language and it's what you saw.

But I cleared the WordPress and WPMl and everything crashes again.

This is really frustrating I have been building WordPress websites since the last 15 years, and I never ran into an unsolvable issue like this.

Thanks for you help, keep looking into this.

September 6, 2019 at 5:27 pm #4526883

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

In order for the language switcher to work when switching from one course page to another the course will need to be translated.

Could you please explain in detailed steps what you do and resuslts in the translations to be deleted? I do not recognize any cache plugin on your site.

Kind regards
Andreas

The topic ‘[Closed] Error for 404 with Sensei courses and lessions’ is closed to new replies.