This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Itamar 5 months ago.

Assigned support staff: Itamar.

Author Posts
May 18, 2019 at 9:19 am #3838589

george-michelK

Hi there,

I received the following email from wordpress:

«
Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

Ici, WordPress a trouvé une erreur avec l’une de vos extensions, « WPML Translation Management ».

First, visit your website and check for any visible issues. Next, visit the page where the error was caught (hidden link.../.../.../admin-ajax.php) and check for any visible issues.

Détails de l’erreur
======================
Une erreur de type E_ERROR a été causée dans la ligne 41 du fichier /.../.../.../.../web/wp-content/plugins/wpml-translation-management/classes/translation-jobs/class-wpml-tm-unsent-jobs.php. Message d’erreur : Uncaught TypeError: Argument 1 passed to WPML_TM_Unsent_Jobs::prepare_unsent_job_for_notice() must be an instance of WPML_Translation_Job, bool given, called in /.../.../.../.../web/wp-includes/class-wp-hook.php on line 288 and defined in /.../.../.../.../web/wp-content/plugins/wpml-translation-management/classes/translation-jobs/class-wpml-tm-unsent-jobs.php:41
Stack trace:
#0 /.../.../.../.../web/wp-includes/class-wp-hook.php(288): WPML_TM_Unsent_Jobs->prepare_unsent_job_for_notice(false)
#1 /.../.../.../.../web/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
#2 /.../.../.../.../web/wp-includes/plugin.php(465): WP_Hook->do_action(Array)
#3 /.../.../.../.../web/wp-content/plugins/wpml-translation-management/inc/translation-jobs/helpers/wpml-update-translation-data-action.class.php(116): do_action('wpml_tm_as
»

Please I need help
Thanks

May 19, 2019 at 7:33 pm #3842437

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for reporting this error.

Please tell me if besides the email that you have got do you also see a problem on your site?
Can you see this error on your site?
Do you know how this error can be triggered?
If you enable WP Debug Log can you see this error in the log?
If so, then please provide me with the WordPress debug.log
Please check this page for instructions.
https://wpml.org/documentation/support/debugging-wpml/
Look under the headline "Enabling the built-in debugging feature in WordPress".
To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);.

Change it to:

define('WP_DEBUG', true);
// Enable Debug logging to the /wp-content/debug.log file
define('WP_DEBUG_LOG', true);
// Disable display of errors and warnings which is recommened on a live site.
define('WP_DEBUG_DISPLAY', false);
@ini_set('display_errors',0);

In this case, the errors will be saved to a debug.log log file inside the /wp-content/directory.
If you can paste your debug.log to pastebin.com and provide me that link, it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in discussion).

Please, could you provide me the additional Info?

Thanks,
Itamar.

May 21, 2019 at 5:06 pm #3857581

george-michelK

Hi dear Itamar,

I have a problem on my site. I opened a ticket about it and it's still in progress. Here is the link: https://wpml.org/forums/topic/compatibility-with-some-shortcodes/

Here is debug.log : https://pastebin.com/4nWhAv3f

Thanks

May 22, 2019 at 3:49 pm #3867467

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for sharing with me the debug log.

I do not see any similar error on the log. In fact, I do not see any error that is related to our plugins. But I've found another forum ticket with an issue that seems to be very similar to yours. You can see it here.
https://wpml.org/forums/topic/wmpl-translation-editor-on-enfold-not-working/#post-3661959

If you are indeed having the same issue, you will encounter a problem to send translations from the Translation Management. Could you please try the following?
1. From WPML > Translation management send a page to Translation basket.
2. From Translation basket send a batch to translation, Batch will be rolled back.
Are you encountering this problem?
If so, then does the 'Uncaught TypeError' shows in the error log?

Regards,
Itamar.

May 23, 2019 at 8:28 am #3872529

george-michelK

Hi dear Itamar,

Currently my only issue have with translations is the previous ticket (https://wpml.org/forums/topic/compatibility-with-some-shortcodes/)

When I received the wordpress mail, I thought that could be the cause of that issue. If not, nothing more to report.

Thanks

May 23, 2019 at 5:46 pm #3878433

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

OK, I see. It might have been some one-time event.
If this message returns please open a new ticket about it.

Best Regards,
Itamar.