This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 3 voices.

Last updated by Shekhar Bhandari 5 months, 3 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
April 10, 2019 at 5:30 pm #3579425

minyongC

I am trying to: upgrade wpml multilingual cms from 3.6.3 to 4.2.5

Link to a page where the issue can be seen: the plugin page after I log in

I expected to see: a lit of plugins

Instead, I got: a blank page with PHP Fatal error: Uncaught Error: Call to a member function get_external_repo() on null in /nas/content/live/stageorange/wp-content/plugins/sitepress-multilingual-cms/vendor/otgs/installer/includes/class-wp-installer.php:2335

April 10, 2019 at 7:09 pm #3580561

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello there,

Welcome to WPML support forum.

While waiting that one of my teammates takes care of your case, please try these steps:

Go to Dashboard -> Updates
Press the "Check again" button
Scroll to the bottom and press the "Update" button

Let us know if it helps.

Kind regards,

Otto

April 11, 2019 at 12:44 pm #3587675

minyongC

Then, I get the same error in this ticket: https://wpml.org/forums/topic/problem-updating-wpml-2/
So I followed the instructions to upgrade in that ticket, but then I get a different error I outlined above.

April 18, 2019 at 3:52 pm #3640515

minyongC

I was wondering if you have any update or any other suggestion. I would try whatever you suggest.

April 19, 2019 at 7:00 am #3643783

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

then I get a different error I outlined above.

Are you talking about the error as mentioned in the screenshot?

Further, could you please perform the below steps and share me the results?

Debugging

1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

Look forward to your reply.

Thanks

April 26, 2019 at 12:46 pm #3690737

minyongC

It works on my local but not on my staging. Let me get back to you on this. You also seem to have come out with a new version, so I also wanted to try that on my staging site.

April 29, 2019 at 6:37 am #3700253

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Sure, I will wait for your feedback.

Thanks

The topic ‘[Closed] Error get_external_repo() on null upgrading to 4.2.5’ is closed to new replies.