This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 6.37 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: I use ACF to create custom post type fields. When I go to edit the field group, every field has an error icon (red !). I do not want to translate the field group, nor the fields so there is no reason for these error icons to show. Solution: Go to each field that has that exclamation mark, select a different value for Translation preferences (like Copy, for example), select back the previous value, and Update the changes to the group.

This topic contains 7 replies, has 2 voices.

Last updated by willR-4 3 months, 2 weeks ago.

Assigned support staff: Radu.

Author Posts
June 21, 2019 at 9:31 am #4065821

willR-4

Potentially related to this ticket but no resolutiono provided: https://wpml.org/forums/topic/acf-error-in-admin/

I am trying to: Remove error icons from fields

Link to a page where the issue can be seen: hidden link

I expected to see: No error icons

Instead, I got: Error icons

I use ACF to create custom post type fields. When I go to edit the field group, every field has an error icon (red !). I do not want to translate the field group, nor the fields so there is no reason for these error icons to show. The ticket referenced above says to save the field group, but this does nothing.

How do I make these error icons go away (and why are they there in the first place)?

June 21, 2019 at 1:54 pm #4067627

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Will,

Thank you for reaching out the WPML support!

Can you tell me if this red bubbles are going away if you deactivate the WPML plugin, please? I just want to see if this is related to WPML plugin or now.
If the red icons are still available, please give me access to the dashboard area and I'll check this a bit closer.

Thanks,
Radu

June 21, 2019 at 4:28 pm #4068347

willR-4

Hi it's definitely wpml error or else I wouldn't have raised a ticket with you. Pls seen screen shot.

I've created an admin user for you. Pls change this ticket so I can give you the username and pw in secret.

June 24, 2019 at 10:42 am #4076621

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Will,

I set the next reply to be private so you can safely send me the credentials.

Thanks,
Radu

June 24, 2019 at 10:53 am #4076715

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Will,

I set your last reply to be private so you can edit it and add the credentials there.

Thanks,
Radu

July 1, 2019 at 5:42 pm #4121453

willR-4

Hi - do you have an update for me?

July 2, 2019 at 7:22 am #4124609

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Will,

Sorry for this delay. I had a look at your website to see what's going on. Can you go to each field that has that exclamation mark, select a different value for Translation preferences (like Copy, for example), select back the previous value, and Update the changes to the group. I did this for the Slider Module field and the exclamation sign is no longer there. Can you give this a try and tell me how it goes, please?

Thanks,
Radu

July 2, 2019 at 9:33 am #4125383

willR-4

I confirm this fixed the problem. This was a rather painful, manual solution since I have many custom field types, each with a lot of fields. The solution was essentially "Have you tried to turning it off and turning it on again". Ideally, the plugin wouldn't throw up unnecessary warnings in the first place