This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Marcel 5 months, 2 weeks ago.

Assigned support staff: Marcel.

Author Posts
April 11, 2019 at 5:11 pm

alexiaS-2

I am trying to:
I want to add these new subdomains:
(For Hong Kong) hk.blog.tryandreview.com
(For Indonesia) id.blog.tryandreview.com
(For Malaysia) my.blog.tryandreview.com
(For Thailand) th.blog.tryandreview.com
(For Vietnam) vn.blog.tryandreview.com
(For Philippines) ph.blog.tryandreview.com
(For Brazil) br.blog.tryandreview.com
(For India) in.blog.tryandreview.com
(For New Zealand) anz.blog.tryandreview.com

Link to a page where the issue can be seen:
hidden link

I expected to see:

Instead, I got: (See image attached)

April 12, 2019 at 9:19 am #3596979

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

Thank you for contacting WPML Support.

The not valid message appears when the settings for different domains per language is not correctly set. Could you please follow this article for setting for different domain per language and check if you have followed the settings perfectly?

As I can't open for example hidden link -> it gets redirected to hidden link

https://wpml.org/faq/server-setting-for-languages-in-different-domains/

I look forward to your reply.

Thanks

Best
Marcel

April 15, 2019 at 3:17 am #3609339

alexiaS-2

Thanks Marcel, I will let my web dev guys know that the subdomains are not set up correctly.

As for these countries, how would you suggest I set them up on my website? These are all english speaking countries with unique content:

(For Philippines) ph.blog.tryandreview.com
(For India) in.blog.tryandreview.com
(For New Zealand) anz.blog.tryandreview.com

April 15, 2019 at 1:36 pm #3613791

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

ok perfect.

If you want to use the same language with different countries you can use a different "hreflang" with region code like "en-PH, en-IN, en-NZ. Then you will not have a duplicate content problem. Is it this what you mean?

Attached you will find documentation how to add the region to your language code. It's visible on the screenshot as "default locale".

https://wpml.org/documentation/support/editing-wpmls-languages-table/

Please let me know 🙂

Best Marcel

April 17, 2019 at 10:16 am #3629427

alexiaS-2

Hi Marcel, I was able to add the additional countries. Thanks for that. But now I am encountering some issues when language switch on our site. Currently our intention is for our website (www.blog.tryandreview.com) to run under 10 different languages which include Singapore, Vietnam, Thailand, Hong Kong, Malaysia, Australia, India, and Brazil. Singapore is our default language.

Switching from Default (SG) to Thailand, Indonesia and Brazil the site worked as intended.
From blog.tryandreview.com to th.blog.tryandreview.com , id.blog.tryandreview.com, and br.blog.tryandreview.com respectively.

But switching from Default (SG) to all other countries does not work.
EG: clicking on Hong Kong language will bring me back to default (blog.tryandreview.com). Attached are the settings I am trying to achieve. As you can see, it all shows "Valid", but when I revert back to the homepage, it isn't working.

April 17, 2019 at 10:23 am #3629569

alexiaS-2

We also faced an issue where we are unable to save our Language URL Format (setting from the screenshot above). So after saving the settings above, I would go back to my settings and the URLs I made adjustments to are back to the previous URLs and shows "not valid".

April 23, 2019 at 8:39 am #3660823

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alexia,

sorry the delay in answering you, as we had Easter holidays here in Europe. I tested now all the settings:

#1 "Switching from Default (SG) to Thailand, Indonesia and Brazil the site worked as intended."
-> Working

#2 "From blog.tryandreview.com to th.blog.tryandreview.com , id.blog.tryandreview.com,
and br.blog.tryandreview.com respectively."
-> What is not working? Or what is the difference to #1?

#3 "switching from Default (SG) to all other countries does not work.
EG: clicking on Hong Kong language will bring me back to default (blog.tryandreview.com). "

... "We also faced an issue where we are unable to save our Language URL Format (setting from the screenshot above). So after saving the settings above, I would go back to my settings and the URLs I made adjustments to are back to the previous URLs and shows "not valid"."
-> All working except:
- Hong Kong -> .blog missing
- Philippines -> .blog missing
- Malaysia -> .blog missing
- New Zealand -> .blog missing
- India -> .blog missing

I was able to see that it removed .blog from Hong Kong after saving and reloading the page. Could you please check the DNS setting from these sites again?

Please let me know

Best
Marcel

April 24, 2019 at 4:36 am #3669261

alexiaS-2

Hi Marcel,
I think I'm just going to wait for a confirmation from the dev team in France. I think the biggest crutch is that our PHP limit is under the recommended value so we keep getting a buggy experience. I will revert back to you after they have confirmed the correct set up for each subdomain and the PHP is adjusted.

Just out of curiosity, does the support team provide services for our website set up? No one is an expert of WPML on our side, so we are contemplating to hire someone to make sure all our subdomains and language switching is set up correctly. Please let me know! Thanks!

April 24, 2019 at 7:55 am #3669913

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alexis,

thank you, yes please let your Dev team confirm the DNS settings.
They can increase the WP_Memory_Limit from 40MB to 256MB with adding following code to wp-config.php:
[/php]define ('WP_MEMORY_LIMIT', '256M');[/php]

We have a network of WPML contractor which you can hire here: https://wpml.org/contractors/

Please let me know when you are ready.

Best
Marcel

May 3, 2019 at 4:35 am #3730735

alexiaS-2

Hi Marcel,
I'm still waiting for the company's dev team to do their part.

I just want to confirm, do you think the WP Memory Limit is causing the current buggy experience now? I can not figure out why, but our default page for Singapore is showing Thai navigation links (Home, News & Features, Community, Try and Review Awards, Influencer Academy).

I've checked the set up of the Home page, Main Menu set up, and WPML setup. I still can not figure out why the main menu on the default page is showing Thai links.. Please see my screenshots for a better explanation.

May 3, 2019 at 11:52 am #3733973

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Alexia, The WP Memory Limit should be always configured, as it's a minimum requirement and can solve many problems. To confirm your DNS do please the following easy test:

- Create on the root folder a file called test.txt.
- Now try to access this file from every domain like domain1.com/test.txt, domain2.tw/test.txt.

You should be able to access the file from every domain. If you have the reply from your dev team, please create a new ticket, as this one is already marked as resolved 🙂

Thank you
Best Marcel