Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by michaelD-67 2 years, 11 months ago.

Assigned support staff: Itamar.

Author Posts
November 30, 2018 at 4:42 pm #2956860

michaelD-67

Dear Supporter,
I have Honor Theme for my client and I know it is 100% compatible with WPML. Unfortunatelly we have a problem with changing the Master Language (Greek) to Second Language (English). From Honor Theme support we receive the followin answer and we want to help us to solve the problem because I can't see solving in the article that they suggest to follow.

Answer From Honor Theme Support:

Kira replied
4 hours ago
Hello,

There is an error when you activate another language

Fatal error: Uncaught InvalidArgumentException: Argument ID must be numeric and greater than 0. in /var/www/108319/108319/documentRoot/wp-content/plugins/sitepress-multilingual-cms/classes/translations/class-wpml-translation-element.php:28 Stack trace: #0 /var/www/108319/108319/documentRoot/wp-content/plugins/sitepress-multilingual-cms/classes/translations/class-wpml-term-element.php(19): WPML_Translation_Element->__construct(NULL, Object(SitePress), Object(WPML_WP_Cache)) #1 /var/www/108319/108319/documentRoot/wp-content/plugins/sitepress-multilingual-cms/classes/translations/class-wpml-menu-element.php(17): WPML_Term_Element->__construct(NULL, Object(SitePress), 'nav_menu', Object(WPML_WP_Cache)) #2 /var/www/108319/108319/documentRoot/wp-content/plugins/sitepress-multilingual-cms/classes/translations/class-wpml-menu-element.php(27): WPML_Menu_Element->__construct(NULL, Object(SitePress), Object(WPML_WP_Cache)) #3 /var/www/108319/108319/documentRoot/wp-content/plugins/sitepress-multilingual-cms/classes/translations/class in /var/www/108319/108319/documentRoot/wp-content/plugins/sitepress-multilingual-cms/classes/translations/class-wpml-translation-element.php on line 28

It refers to the WPML plugin itself. I found this guide. Please, check it

https://wpml.org/forums/topic/argument-id-must-be-numeric-and-greater-than-0-3/

Best regards,

Kira Burns

Support team

Thanks in advance!

December 3, 2018 at 12:19 pm #2962113

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

Thank you for contacting the WPML support forum.

It is not clear yet whether you have the same issue as the one in the referred ticket.
The solution in that ticket is brought by the user that opened the ticket here.
https://wpml.org/forums/topic/argument-id-must-be-numeric-and-greater-than-0-3/#post-2686534
And also by another user here.
https://wpml.org/forums/topic/argument-id-must-be-numeric-and-greater-than-0-3/#post-2728881
The issue in that ticket is coming from the WPBakery Page Builder plugin. You are also using the WPBakery Page Builder plugin. So my first request from you is to update the WPBakery Page Builder plugin since it seems that you are using an old version of it, and see if the problem gets solved.
Can you please try it and see if it helps?

Furthermore, it is important for me to mention that the Honor theme (hidden link) by AncoraThemes is not officially compatible with WPML.
https://wpml.org/documentation/theme-compatibility/
Not being on this list does not mean that it is not compatible it just means we do not know yet if it is. Please understand that we cannot be responsible for the compatibility statement from the theme author.

To check whether it is an issue with the theme, please try the following.
Please switch the theme from the Honor theme to a default WordPress theme (TwebtySeventeen, for example) and tell me if the issue persists.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

I look forward to your reply!

Thanks,
Itamar.

December 3, 2018 at 5:32 pm #2963658

michaelD-67

Dear Sir,
Thank you for your support.
I make the changes that you sugest me and the result is the same. I update the WPBakery Page Builder in last version V.5.6 and also I change the theme from Honor to TwentyTwelve and the result is the same error. I attach a screenshot to see. I believe the problem is in WPLM and also my supporter from Honor theme.

Thanks in advance!
Michael Diamantidis
Vision Computer Applications
Greece

elps_en.png
December 4, 2018 at 4:49 pm #2967423

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and thanks for trying my suggestions.

Could you please run another test?
I suspect that there is a collision with another plugin.
If possible get your site into a minimum environment.
Minimum environment means switching to a default WordPress theme like Twentyseventeen and no plugins activated but WPML.
Is it possible for you to try it?
You will need first to check if the problem persists when just the theme is switched to Twentyseventeen (we know that the issue in your case is not the Honor theme but please proceed like this).
If it persists then turn off all plugins but the WPML and its add-ons and WooCommerce itself (without any of its add-ons active).
Then please check if the problem persists.
If it does not persists so start by activating the plugins one by one and check when the problem comes back then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

Thanks,
Itamar.

December 4, 2018 at 7:13 pm #2967844

michaelD-67

Dear Sir,
Thank you for your support.
I make all the steps that you describe. Only when deactivate WPML and it's addons the English Page works. In all other cases I have the same error.

Thanks in advance!
Michael Diamantidis
Vision Computer Applications
Greece

December 4, 2018 at 9:40 pm #2968156

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi, Michael.

Please see the above private reply.

Thanks,
Itamar.

December 5, 2018 at 7:29 am #2969032

michaelD-67

Dear Sir,
The migration is DONE. I waiting from you the solution to my problem because my client wants to finish this week.

Thanks in advance!
Michael Diamantidis
Vision Computer Applications
Greece

December 5, 2018 at 10:10 pm #2971841

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi, Michael and thanks for setting your site on our test server.

I'm debugging the issue on your site and will be able to reply here tomorrow after I have some more information.

Thank you for your patience.

Itamar.

December 6, 2018 at 9:17 am #2973070

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi there.

I've checked some more things on the test server. Currently, I'm consulting our second their supporters about this issue. We'll keep you updated here.

Regards,
Itamar.

December 6, 2018 at 12:47 pm #2973901

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

I've escalated this ticket to our second tier supporters and they will check the issue.
We'll keep you updated here.

Thank you for your patience.

Itamar.

December 6, 2018 at 4:25 pm #2974980

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

Our second tier supporter has found the problem and how to fix it. It a record in the DB that needs to be deleted. Once deleted the fatal error does not occur anymore when you switch to the English language. I've tested it on your site that is on our test server, and you can try it here. hidden link
Please note that the site in the minimum environment and that is why it looks this way.

Here is what you need to do on your site in order to fix this issue.

1. Take a full backup of the DB of the site.

2. Access the DB with PHPMyAdmin (or whatever you use for managing your DB).

3. Run this SQL command.

SELECT *
FROM `wp_icl_translations`
WHERE `trid` = '580'
AND `translation_id` = '459'

4. You will get one row with the values as shown in the attached screenshot. Please see the attached screenshot trid-580.png.

5. Delete this row.

6. Go to the front-end and switch from Greek into English and the problem should be gone.

Please let me know if it is working for you.
If you need help with this, then please take a backup of your DB and let me know and I'll do it for you. I'll need to install the ARI Adminer plugin to do that. https://wordpress.org/plugins/ari-adminer/


**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

If it working for you, I'd appreciate if you mark this ticket as resolved.

Thanks,
Itamar.

trid-580.png
December 10, 2018 at 9:32 am #2983268

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi there.

There is another way that you can get this problem fixed. Before applying the above DB fix please try the following.
1. Make a backup of the DB of your site.
2. Go to WPML -> Support -> Troubleshooting (link).
3. Press the 'Remove ghost entries from the translation tables' button and wait for the process to finish.
According to our checks, this should also fix this issue.

Please let me know if it does.

Thanks,
Itamar.

December 10, 2018 at 10:58 am #2983669

michaelD-67

My issue is resolved now. Thank you! My Host Provider does not allow to made changes in the Database so this solution works perfect.
Thanks in advance!
Michael Diamantidis
Vision Computer Applications
Greece