This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Error: "invalid value posted for Product" when adding to chart

Solution: There was a additional space added after the comma in the attribute product translations, fixing it solved the issue.

This topic contains 13 replies, has 2 voices.

Last updated by sladjanJ 2 weeks, 5 days ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
September 17, 2019 at 7:16 am #4586029

sladjanJ

I'm running two-languages webiste, English(primary) and Serbian(secondary).

Only for Serbian version, only for some product and only for particular variations I get this error:
"Neispravna vrednost objavljena za Product"
-english translation of error message:
"invalid value posted for Product" - where "Product" is an attribute name

Steps to reproduce:
-go to link: hidden link
-from variation drop-down choose the third option from bottom named "SET 1: KRAVATA, MAŠNA ZA ODRASLE, MARAMICA, REVER CVETIĆ, MANŽETNE"
-add it to cart (serbian: "DODAJ U KORPU")
-error will occur

This is happening for couple of products but not for all and only for variations similar to this one from example above.
Error is also present with "default" theme.

September 18, 2019 at 5:16 am #4592487

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

The debug info provides information about theme and plugins information but not the php error. so can you follow the same steps and check if there is any debug.log file in the wp-content folder? If yes, can you paste that .log file contents here, if it's long I recommend you to use pastebin.com.

Thanks

September 18, 2019 at 9:45 am #4594463

sladjanJ

Hi,

Can I just use the log from that day if exist? I would like to avoid running website on minimal setup again, it's a production website you know. If I need to switch it to minimal setup again, please tell me everything that you need so I don't have to it for the third time.

Thanks.

September 19, 2019 at 4:58 am #4601263

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Yes, if the error was present there you can provide us the log, that would help, but if the log is empty you should perform those steps again to see if there is any error.

Look forward to your reply.

Thanks

September 19, 2019 at 8:10 pm #4608215

sladjanJ

Hi,

I tried it again and now I can confirm that there are no php error. The file debug.log don't exist.

Thanks

September 20, 2019 at 3:18 am #4609117

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

To further debug this issue, could you please provide me a backup of your site so I can replicate your site on my localhost and perform further debugging.

To send a backup file you can use backups plugins, or use hosting services back up and send it using google drive, dropbox, etc to us. If you can, I request you to remove the uploads folder from the backup as it will be easy to download due to the size.

I have enabled the private reply so you can send those links in the private reply. If you use some backup plugins installed and you created the packages, you can just provide login details and mention us, we can download it from the site itself.
hidden link

Look forward to your reply.

Thanks

September 23, 2019 at 8:00 am #4621449

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I replicated your site on my localhost and with the mentioned product I couldn't reproduce the issue as it's added properly to the cart, so can you please provide few examples of other products where I can reproduce this issue?

Look forward to your reply.

Thanks

September 23, 2019 at 9:34 am #4621955

sladjanJ

Hi,

Wow, really strange to happen. Don't forget to follow all the steps written above(e.g. use Serbian version). Please try some of these products(just add this to root adress):
- /proizvod/retro-kravata-6/?lang=sr
- /proizvod/retro-kravata-3/?lang=sr
- /proizvod/cvetna-kravata-4/?lang=sr
-/proizvod/cvetna-kravata-6/?lang=sr

And again, as stated in steps above, you have to choose third variation from bottom up.

Thanks!

September 24, 2019 at 8:09 am #4628961

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I am not able to replicate the issue with the mentioned product to in my localhost, so I am creating a online test server to test the issue, I will update you as soon as I will have further feedback.

Thanks

September 25, 2019 at 5:39 am #4635743

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I have replicated the issue on a test server and can replicate the issue. Being so, I am currently discussing this issue with our 2nd tier supporter and will respond to you soon.

Thanks

September 25, 2019 at 6:31 am #4635935

sladjanJ

Hi,

Ok, thank you, it's good we are on the same line for the start.
I'm awaiting for their response,

Thanks!

September 25, 2019 at 7:05 am #4636141

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Sure, I will update you further as soon as I will have any feedback available.

Thank you so much for your patience. 🙂

September 26, 2019 at 1:40 am #4642449

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

There is an extra space after the comma on the translated attributes creating the issue, can you please fix this to solve the issue.

Set 1: Kravata, Mašna za odrasle,  Maramica, Rever Cvetić, Manžetne"

with

Set 1: Kravata, Mašna za odrasle, Maramica, Rever Cvetić, Manžetne"

Let me know if this helps.

Thanks

September 26, 2019 at 5:07 pm #4649213

sladjanJ

OMG, I can't believe that I took so much of your time for my stupid typo. Thank you so much for your help, you've been a great supporter!