Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Client reported 508 resouce limit reached error when trying to edit translations

Solution: Disabling php-fpm at server lever resolved the issue

This topic contains 26 replies, has 3 voices.

Last updated by rodS-2 2 weeks, 3 days ago.

Assigned support staff: Raja Mohammed.

Author Posts
November 11, 2019 at 9:00 am #4922741

rodS-2

Sorry Raja, our Developers have advised that they could not see any logs in the WordPress debug.log file and so the data on the pastebin.com link is the server log. Can you please advise if this helps. Thanks.

November 11, 2019 at 11:58 am #4924717

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the details. There is nothing much related to WPML in the logs. It would be better if you can grant a temporary access with admin privilege so that I can check for a few settings.

To make sure I am still on the same page, I hope you are still encountering a 508 error on every page update? If there is any other way I could reproduce the issue please let me know.

You will find the needed fields to share the access details below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

Kind regards
Raja

November 12, 2019 at 8:18 am #4929527

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the access. I am checking the details. I will keep you posted with any updates.

November 12, 2019 at 11:06 am #4930995

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I haven't encountered the 508 error yet, I have tried to update the About us page with a minor edit to the title with 4 tabs open at the same time. I have also tried updating the pages simultaneously on different tabs yet the issue cannot be reproduced.

It would be good if you can record your steps using a screen recorder (hidden link) and share the link with me. So that it would be easy for me to follow the same and reproduce from my end.

Kind regards
Raja

November 13, 2019 at 12:17 am #4935329

rodS-2

Hi Raja,

I have recorded a video using Loom which can be accessed here:
hidden link

You will notice that sometimes the 508 error appears, sometimes everything updates fine, and other times we receive the "connection lost" error. When errors are experienced, it takes some time but they then clear and update.

You will notice that the easiest way to replicate the issue is to open 4 tabs and make quick edits between tabs which I believe calls extra resources (or whatever is causing this issue) hence the error we receive.

Please keep in mind that we are able to replicate this issue even just when editing one tab.

Please let me know how you go.
Thanks, Chelsea.

November 13, 2019 at 7:01 am #4936023

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the video, however, I am still unable to reproduce it on my side. I tried the same steps and increased the number of tabs for 4 to 10 still the issue cannot be encountered.

Please refer: hidden link

I would request your permission to install debug objects plugin to see the query and page load profile this will give me some idea to identify any possible causing agents.

I would also suggest to Logout from all sessions this can be done form Users > Your profile Find the button 'Logout from all session' login again. Let me know the results.

Kind regards
Raja

November 14, 2019 at 12:23 am #4943555

rodS-2

Hi Raja,

Your video would suggest that you have not tested this as per my instructions. It appears you have simply opened multiple tabs and waited for them to load? Unfortunately, this is not the way in which to replicate the issue.

Please follow the below steps specifically:

1. Open 4 pages in new tabs for editing
2. Add a dot point to page 1 title and update
3. Add a dot point to page 2 title and update
4. Add a dot point to page 3 title and update
5. Add a dot point to page 4 title and update
6. Remove dot point from page 1 and update
7. Remove dot point from page 2 and update
8. Remove dot point from page 3 and update
9. Remove dot point from page 4 and update
10. Repeat steps 2 - 9 until the issue can be reproduced.
This takes me 1 or 2 round to achieve.

As requested to your colleague previously, is there anyway we could schedule a video call or teleconference to discuss this in live time? I understand that this is not offered as part of support, but the process of going back and forth via this forum is taking far to long with the time difference etc. and I believe we can come to a conclusion much more efficiently in live time. Could you please consider this?

I only ask as if we cannot come to a conclusion in the next couple of days, we will need to consider leaving the WPML plugin and trying something else and/or trying some other options... We'd obviously like to continue with WPML but if we cannot reach a solution we will have no choice but to choose a new plugin.

I look forward to your feedback. Please let me know ASAP.
Thanks, Chelsea.

November 14, 2019 at 5:50 am #4944127

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello Chelsea.

I have performed the steps as mentioned in your previous reply and repeated that for 4 -5 sets updating the English and Chinese translation yet I could not encounter the 508 issues. It doesn't mean the error is resolved maybe something still needs to be addressed here.

I have installed the Query monitor plugin to the site to get details about the backend processes, I have noticed a general slowness which might be due to several reasons

1) W3 total cache database cache is Enable. This one caches the results of common database queries. It can hog server resources and, on a shared server, may actually work against you. It’s best to skip this option. I have disabled it and I can see some improvement in the performance

hidden link

2) I see WPML icl_strings has some records which is also slowing down the process. I have optimized the table from WPML > Support > Troubleshooting > Optimize and Recreate ST tables. This has improved the performance way better and the load time reduced from around 18s to 3s

I would request you please check the site again by clearing the browser and site cache. Let me know if the 508 Resource error still persists.

Screencast of the steps performed hidden link (10 min long video)

Let me know the results.

Kind regards
Raja

November 14, 2019 at 7:10 am #4944289

rodS-2

Hi Raja,

I have cleared my cache and completed a hard reload but the issue still presents itself.
I get the "Connection Lost" error within the CMS.

What are your thoughts on arranging a teleconference to trouble shoot this?
Do you have any other suggestions?

Thanks, Chelsea.

November 14, 2019 at 10:53 am #4945939

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I am afraid a video conference is not possible at the moment.
Would you mind sharing the Cpanel access let me try to fetch the resource logs that might give some idea? I have enabled private fields for the same.

I have tested the site using the Query monitor plugin, I couldn't find any blocking execution happening from WPML, which also does not give us a clear idea about the issue and during test no instance of 508 error has been encountered

Since I and the other supporter Bruno is not able to reproduce the issue from our side, The other best option is to move the site to our private server in order to reproduce the issue. Maybe you can check the same steps in our private server and observe the happenings. If that sounds good I can send you the migration steps to move the site to our private server in my next reply.

If the issue cannot be reproduced on our server and it is happening in a particular instance then it should be related to the server environment there might be some tweaks required to be done on the environment. This is the best way to deal with any of the server related errors.

There is also something that you can try, If you are using a different login other than the one shared with us try using the temporary login check if the issue persists. This might not sound logical but sometime it might help.

Kind regards
Raja

November 20, 2019 at 1:09 am #4976317

rodS-2

Hi Raja,

We have managed to resolve this issue (for now) by disabling php-fpm at a server level. Just wanted to let you know over this forum, so that the solution is visible to others that may be experiencing this issue.

We'll reach out if the issue continues, but looks like we're good to go.
Thanks, Chelsea.

November 20, 2019 at 1:11 am #4976319

rodS-2

Thanks guys.