This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by krasimirD-2 2 months, 3 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
July 17, 2019 at 9:32 am #4228229

krasimirD-2

Tell us what you are trying to do?
I searched in the forum but I can't find any answers suitable for me with the languages per directories error.

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site?
hidden link

July 17, 2019 at 11:10 am #4229265

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will help you with your issue.

Could you please post the entire error message a screenshot would be of great help.

In some cases the error might be a false error (false positive) to confirm this we highly recommend Type the test call in your browser URL in the below format
hidden link

When you make this call, you’ll get a blank looking page. Its content (which you can see by looking at the page’s source) should return your site URL in XML format eg: <!--hidden link;, If that is the case then you can ignore the warning message and continue using the directory URL for each language.

In most case, the error is related to the .htaccess file is not writable on your site also make sure the URL rewrite is enabled for your site.

Please refer https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/#make-sure-that-wordpress-enables-url-rewriting

please let me know if you need further assistance

Kind regards
Raja

July 17, 2019 at 12:29 pm #4230017

krasimirD-2

Hello, I upload 2 images with admin error, httacess file and the blank page witch not showing my url in XML format... I check the .httaccses file and it has the rewriting "function".

July 18, 2019 at 11:01 am #4237859

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the information, Please share temporary access to your site, Let me check for a few parameters for more information about the issue. I have enabled private fields for you to securely share the details.

Kind regards
Raja

July 19, 2019 at 5:10 am #4243953

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for your access,

I have checked your site in detail. I can confirm that the directory URL for languages works fine without any issue, I am able to access the english shop page after allowing the user to view the hidden languages (screenshot attached).

Since the directory URL format works as expected you can ignore the warning notice, Some time the notice might be a false error which is similar in your case as well. I hope you can continue using directory URL format without any issues.

PS: In case if you are not aware of the fact that the hidden languages will be visible only to the user who has the access (Display hidden languages) enabled in their profile settings.

Please let me know if you need any further assistance.

Kind regards
Raja

July 22, 2019 at 6:15 am #4254137

krasimirD-2

My issue is resolved now. Thank you!