This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

If you have the same issue on your site please open a new ticket in our forum and we'll investigate the issue.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by romainO-2 1 month ago.

Assigned support staff: Itamar.

Author Posts
September 13, 2019 at 10:43 am

romainO-2

Hi,

I have deactivated qtranslate, installed WPML and manually created all page language versions using divi theme.

All seems ok except this message :

Il manque des enregistrements dans les tableaux de langues et WPML ne peut fonctionner correctement tant que le problème n'est pas résolu.
Veuillez vous rendre à la page Dépannage et cliquer sur "Effacer les informations linguistiques et reconstituer les langues à nouveau" pour résoudre le problème.

But I don't know how to fix it.

Also, the footer menu, strangely, does not display with the same style as in French.

September 15, 2019 at 7:38 pm #4575355

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

To fix the issue in the message, please do the following.
1. Take a backup of the DB of your site.

2. Go to the troubleshooting section on your site here.
hidden link

3. Once on the troubleshooting screen press the following buttons and check if it helps. Press each button at a time and wait for the process to complete.
- 'Clear the cache in WPML'
- 'Remove ghost entries from the translation tables'
- 'Fix element_type collation'
- 'Set language information'
- 'Assign translation status to duplicated content'
- 'Fix post type assignment for translations'

*** Please make a backup of your database before using this.***

Then please check if the message still shows. Please remember to refresh the admin page.

Thanks,
Itamar.

September 16, 2019 at 9:12 am #4577805

romainO-2

Hi,

Done, but the message still shows.

September 16, 2019 at 8:49 pm #4584095

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for trying my suggestions.

I can see that the message is still showing.
Can you please tell me if besides the message that is showing you recognize any other issue?
Or is it the message itself that bothers you?

To continue checking this issue, I'm going to need to check things on the DB of your site. For this, I need to install the Adminer script (hidden link).
Do you allow me to install this script on your site and examine the DB?

Thanks,
Itamar.

September 17, 2019 at 7:15 am #4586027

romainO-2

Hello,

Besides the message that is showing, there are 2 other strange display :

- Footer menu in english which is left-align and bold (no custom css added)
- Blank space below all project page content

Ok you can examine the DB. Thank you.

September 18, 2019 at 3:59 am #4592349

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I've checked the DB of your site and everything seems ok as far as it concerns the languages tables of WPML. It appears that the message was stuck with no real problem on the DB. By removing the key from the icl_admin_messages option in the _options table, I resolved the issue. The message is not showing anymore. I've removed the Adminer script from your site.

The other issues that you bring here do not seem to be related to this the main issue of this ticket. In our forum, we try to keep one issue per ticket. Continuing with one ticket per issue helps not only supporters to focus on one issue at once, but also enables other users to find solutions to their questions faster.
Could you please confirm that the issue is solved on your site and mark this ticket as resolved?
Please open a new ticket or chat for the other issues.

Thanks,
Itamar.

September 18, 2019 at 6:02 am #4592641

romainO-2

ok the error message is not showing any more. Thank you.