Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: After updating WPML, the client is receiving the following message:

Debug information WPML Update is Incomplete

You are running updated gravityforms-multilingual and wpml-media-translation, but the following components are not updated: sitepress-multilingual-cms wpml-string-translation wpml-translation-management Your site will not work as it should in this configuration Please update all components which you are using. For WPML components you can receive updates from your WPML.org account or automatically, after you register WPML.

But all plugins are updated and the site is registered with WPML.

Solution: Manually installing the latest WPML plugins by following these steps resolved the issue:

1. Backup your database – see for example: http://wordpress.org/extend/plugins/wp-db-backup/

2. Deactivate the existing WPML plugin and any add-ons.

3. Delete the plugin files – this does not delete your translations. You will simply delete the plugin files from you "wp-content/plugins" folder NOT the database records.

4. Download the updated plugin from https://wpml.org/account/downloads/ and upload to the plugin directory.

5. Activate the WPML plugin and any add-ons.

This topic contains 2 replies, has 2 voices.

Last updated by Nina Gonzalez 3 years, 5 months ago.

Assigned support staff: Lauren.

Author Posts
August 16, 2016 at 5:08 pm #1005617

Nina Gonzalez

I am trying to: I just upgraded my plugins and I am receiving the following message:

Debug information
WPML Update is Incomplete

You are running updated gravityforms-multilingual and wpml-media-translation, but the following components are not updated:
sitepress-multilingual-cms
wpml-string-translation
wpml-translation-management
Your site will not work as it should in this configuration Please update all components which you are using. For WPML components you can receive updates from your WPML.org account or automatically, after you register WPML.

But all of my plugins are updated and I am already registered with WPML>

URL of (my) website where problem appears: earthcharter.org

I expected to see:

Instead, I got:

Steps to duplicate the issue:

August 16, 2016 at 10:18 pm #1005948

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-05:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Please try increasing the WP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/. You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Then, I would suggest manually installing the latest WPML plugins by following these steps:

1. Backup your database – see for example: http://wordpress.org/extend/plugins/wp-db-backup/

2. Deactivate the existing WPML plugin and any add-ons.

3. Delete the plugin files – this does not delete your translations. You will simply delete the plugin files from you "wp-content/plugins" folder NOT the database records.

4. Download the updated plugin from https://wpml.org/account/downloads/ and upload to the plugin directory.

5. Activate the WPML plugin and any add-ons.

Please let me know if this resolves the issue or if you need further assistance. Thanks!

August 31, 2016 at 2:56 pm #1046951

Nina Gonzalez

This worked, thanks for your help.