This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The error message "WPML can't find the translation service. Please contact WPML Support or your translation service provider." will not disappear.

Solution: 0. Make a bactup of your database for saftey 1. Go to WPML > Support > Troubleshooting (you should scroll down the page to find this) 2. Find the section "Reset Professional translation state" 3. Tick the box 4. Press the "Reset Professional Translation State" blue box button.

If the blue box button does not appear then try this: 1. Visit the Translation Managmement/ Translators page 2. Go to WPML > Support > Troubleshooting >Reset Professional translation state

The blue button should be there now.

Relevant Documentation: none

This topic contains 7 replies, has 2 voices.

Last updated by clf 3 years, 6 months ago.

Assigned support staff: Yvette.

Author Posts
February 19, 2016 at 9:36 am #818002

clf

The error message "WPML can't find the translation service. Please contact WPML Support or your translation service provider." will not disappear. I do not use a translation service, I have tried all sort of things including getting my provider to increase MaxInputVars to 10000.

I have had this issue before and was helped by Mohammad:

https://wpml.org/forums/topic/wpml-cant-find-the-translation-service-please-contact-wpml-support-or-your-tra-2/

I would appreciate a permanent fix 🙂 or if possible just a walk through so that I can fix it myself the next time if happens.

February 19, 2016 at 4:53 pm #818614

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello.

I reviewed the ticket you posted and the manner in which the message was cleared is not something we would normally detail in a forum as it involves the direct maniuplation of the database and WPML parameters.

Could you please try to do the following steps instead:

0. Make a backtup of your database for saftey
1. Go to WPML > Support > Troubleshooting (you should scroll down the page to find this)
2. Find the section "Reset Professional translation state"
3. Tick the box
4. Press the "Reset Professional Translation State" blue box button.

Can you please advise if this worked...if it did not, then I can repeat the process that my colleague did previously. I will mark the private area for you to open access to your system in the case that the above steps did not work.

Thank you

February 22, 2016 at 3:02 pm #820177

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Please check again.

This time, I did the following:
1. Go to the support page again
2. Select button "Enable other translation services" (this was not there before)
3. Once again press the "Reset Professional Translation State" blue box button
4. Visit the Translation Managmement/ Translators

Then the system message disappeared. Can you confirm that this is the case for you as well?

If so, then the complete steps to remove this message seem to be:
0. Make a backtup of your database for saftey
1. Go to WPML > Support > Troubleshooting (you should scroll down the page to find this)
2. Find the section "Reset Professional translation state"
3. Tick the box
4. Press the "Reset Professional Translation State" blue box button.
5. Select button "Enable other translation services" (this button will appear after step 4)
6. Once again press the "Reset Professional Translation State" blue box button
7. Visit the Translation Managmement/ Translators

February 23, 2016 at 9:53 am #820860

clf

I can see that this has worked on my staging site - but when I try this on my live site, the "Enable other translation services" button doesn't show up 🙁

February 23, 2016 at 12:30 pm #821078

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hmmm - this happened to me as well in the staging site.

I had to exit the screen and then go in again...and there it was!
Can you try to do these steps:

1. Visit the Translation Managmement/ Translators page
2. Go to WPML > Support > Troubleshooting >Reset Professional translation state
3. Is the blue button there now?

This is what I did inadvertantly as I was looking for that Blue Button....and then it appeared after looking at the Translation Management screens.

Please let me know. Otherwise, like we said previously, we can always re-execute the database manipulation...but it would be better to not have to do this and I can also clarify the process to our 2nd tier supporters who are following this ticket. In that way the can correct whatever is not working as it should.

Thanks for your patience.

February 24, 2016 at 11:25 am #822159

clf

Still no "Enable other translation services" button - but now the error message is gone!

Yesterday I tried several times, and exited, and tried again. Today I tried resetting, visited Translation Management / Translators page tried resetting again and then it was gone?

Anyway, thanks! 🙂

February 24, 2016 at 11:45 am #822187

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Ok - thanks for this additional information.

I am sorry we could not nail down the exact steps to clear the message but I am glad that we did not have to attack the database directly. It´s always better to find alternatives than that.

Hopefully with the next release this annoying issue will go away and you will not have to repeat these steps.

March 10, 2016 at 9:16 am #834571

clf

Thanks Yvette 🙂