This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: When I enable WPML I get this error: PHP Fatal error: Uncaught Error: Call to undefined method stdClass::is_enabled()

Solution: There is a corrupt record in the database. To solve the issue, try by manually changing the value for the wpml_language_switcher option in the wp-options table to be the same as a new WPML installation.

0% of people find this useful.

This topic contains 9 replies, has 2 voices.

Last updated by jacquesB-7 3 months, 2 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
June 21, 2019 at 2:22 pm #4067771

jacquesB-7

I made the migration of my new site campinglerayondesoleil.mediaprimweb.com to campinglerayondesoleil.com and I have a problem with WPML:

This plugin failed to load properly and is paused during recovery mode.
An error of type E_ERROR was caused in line 346 of the file /home/fxjds1xdu4o2/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-settings.php. Error message: Uncaught Error: Call to undefined method stdClass::is_enabled() in /home/fxjds1xdu4o2/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-settings.php:346 Stack trace: #0 /home/fxjds1xdu4o2/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-inline-styles.php(274): WPML_LS_Settings->get_active_slots() #1 /home/fxjds1xdu4o2/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-admin-ui.php(105): WPML_LS_Inline_Styles->admin_output() #2 /home/fxjds1xdu4o2/public_html/wp-includes/class-wp-hook.php(286): WPML_LS_Admin_UI->admin_head_action('') #3 /home/fxjds1xdu4o2/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #4 /home/fxjds1xdu4o2/public_html/wp-includes/plugin.php(465): WP_Hook->do_action(Array) #5 /home/fxjds1xdu4o2/public_html/wp-admin/admin-header.php(149): do_action('admin_head') #6 /home/fxjds1xdu4o2/public_html/wp-admin/index.php(111)

June 24, 2019 at 5:39 am #4074653

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

Could you please disable all wpml plugins and enable only the core WPML plugin (site press-multilingual-cms) only once and see if that helps?

Further, can you confirm that you are still experiencing issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Nineteen)

Look forward to your reply.

Thanks

June 25, 2019 at 2:41 pm #4085571

jacquesB-7

Hello team WPML. I tried what you told me and it does not work. The extension worked well with my Divi theme when I built the site on a subdomain. Can the problem be due to hosting at godaddy? Here is the error code that I have:

WPML Multilingual CMS | Documentation | WPML 3.9.1 release notes
Version 3.9.1 | By OnTheGoSystems | Visit plugin site

This plugin failed to load properly and is paused during recovery mode.

An error of type E_ERROR was caused in line 343 of the file /home/fxjds1xdu4o2/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-settings.php. Error message: Uncaught Error: Call to undefined method stdClass::is_enabled() in /home/fxjds1xdu4o2/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-settings.php:343 Stack trace: #0 /home/fxjds1xdu4o2/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-inline-styles.php(274): WPML_LS_Settings->get_active_slots() #1 /home/fxjds1xdu4o2/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-admin-ui.php(104): WPML_LS_Inline_Styles->admin_output() #2 /home/fxjds1xdu4o2/public_html/wp-includes/class-wp-hook.php(286): WPML_LS_Admin_UI->admin_head_action('') #3 /home/fxjds1xdu4o2/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #4 /home/fxjds1xdu4o2/public_html/wp-includes/plugin.php(465): WP_Hook->do_action(Array) #5 /home/fxjds1xdu4o2/public_html/wp-admin/admin-header.php(149): do_action('admin_head') #6 /home/fxjds1xdu4o2/public_html/wp-admin/index.php(111)

Thank for your help

June 26, 2019 at 3:10 am #4088417

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I have no further clue here, so to debug this issue further, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

June 27, 2019 at 3:41 am #4096419

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can see that you are trying to use WPML Multilingual CMS 3.9.1 which is outdated, so could you please follow the below steps and let me know if this helps:

❌ Backup your website and database ❌
• Deactivate/Delete the “Installer” plugin (if you have it)
• Deactivate all WPML plugins
• Login via FTP to your wp-content/plugins folder
• Delete all WPML folders
• Go to http://wpml.org/my-account/downloads/ and download the latest stable WPML Multilingual CMS Plugin, then extract it.
• Upload the plugin via FTP to the wp-content/plugins folder.
⌥ alternatively you could upload the .zip file using Dashboard > Plugins > New > Upload
• Activate the WPML plugin via WP Dashboard > Plugins
• Complete the setup, if needed
• Register WPML for your site (at the end of setup, clic on “generate key” button)
• Navigate to Dashboard > Plugins and locate WPML Multilingual CMS
• Clic on the blue link that says “Registered”
• Download and activate all needed WPML AddOn Plugins

This should not generate any problems.

⌥ In case you want to register WPML for your site manually please make sure to enter the naked URL of your site in wpml.org (something like hidden link)

⌥ In the extreme case, please try to register with all non-WPML Plugins deactivated,
and Theme Twenty sixteen enabled.

This should fix the issue. Let me know how it goes.

Thanks

July 2, 2019 at 4:33 pm #4128757

jacquesB-7

Hello team WPML. I also tried what you told me and it still does not work. Can the problem be due to hosting at godaddy? Here is the error code that I have:

This plugin failed to load properly and is paused during recovery mode.

An error of type E_ERROR was caused in line 346 of the file /home/fxjds1xdu4o2/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-settings.php. Error message: Uncaught Error: Call to undefined method stdClass::is_enabled() in /home/fxjds1xdu4o2/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-settings.php:346 Stack trace: #0 /home/fxjds1xdu4o2/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-inline-styles.php(274): WPML_LS_Settings->get_active_slots() #1 /home/fxjds1xdu4o2/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/language-switcher/class-wpml-ls-admin-ui.php(105): WPML_LS_Inline_Styles->admin_output() #2 /home/fxjds1xdu4o2/public_html/wp-includes/class-wp-hook.php(286): WPML_LS_Admin_UI->admin_head_action('') #3 /home/fxjds1xdu4o2/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #4 /home/fxjds1xdu4o2/public_html/wp-includes/plugin.php(465): WP_Hook->do_action(Array) #5 /home/fxjds1xdu4o2/public_html/wp-admin/admin-header.php(149): do_action('admin_head') #6 /home/fxjds1xdu4o2/public_html/wp-admin/index.php(111)

Waiting news from you
Thank you so much

July 3, 2019 at 3:18 am #4131351

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I followed the steps as mentioned here and the issue is resolved for me so could you please check once and confirm?
https://wpml.org/forums/topic/wpml-ssl-fatal-error/

Look forward to your reply.

Thanks

July 3, 2019 at 3:05 pm #4137751

jacquesB-7

ok I can try it but how do I do it? How can I change the value for the wpml_language_switcher?

Thank you

July 4, 2019 at 3:20 am #4140035

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I already fixed the issue on your end, so you can just check the issue and confirm if it's resolved.

Thanks

July 4, 2019 at 7:56 pm #4146291

jacquesB-7

My issue is resolved now. Thank you very much to Shekhar Bhandari and all the team WPML!