This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Noman 2 months, 3 weeks ago.

Assigned support staff: Noman.

Author Posts
July 23, 2019 at 3:15 pm #4267357

codemotionS

I am trying to:
Activate the WPML plugin but i receive the error

I expected to see:
Plugin activated

Instead, I got:
"WPML is missing some records in the languages tables and it cannot fully work until this issue is fixed.
Please go to the Troubleshooting page and click on "Clear language information and repopulate languages" to fix this problem.

This warning will disappear once this issue is fixed."

I tried any solutions found on the forum but no one worked for me.
The stranger thing is taht in my local install of wordpress i had no issue on activation.

My WP configuration is:
- WP on Bedrock
- All In One SEO Pack
- Beaver Builder Plugin
- Head, Footer and Post Injections
- Pixel Caffeine
- Really Simple SSL
- W3 Total Cache
- Custom theme build on Sage

I already tried to deactivate all plugins before to install WPML

July 23, 2019 at 3:58 pm #4267797

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML support. Could you please follow below steps and let me know how it goes?

=== Please backup your database and website ===

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40MB as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

2. You are using an older version of WordPress on your site, please backup your site and update WordPress to it’s latest version 5.2.2.

3. It seems you have just installed WPML plugins and configuring WPML first time on this site and do not have any translated data yet then you can fix this issue by removing WPML and all its data completely from database.
To do so:
- Please go to WPML >> Support >> Troubleshooting (the link is at the bottom of the support page). >> There, click on “Reset and deactivate WPML” >> then Delete the plugin.

OR

- If you face any issue in accessing WPML >> Support >> Troubleshooting page then please go to *_options database table and delete the ‘icl_sitepress_settings’ entry. This caused WPML to start over with set up.

4. After deleting all WPML data and WPML related plugins then please install WPML plugins again and I hope now you will not face any issue.

This issue usually happens due to some corruption in the database, if you are installing WPML first time in this site and you see some database tables starting with <srtong>icl_</srtong> even after reset, please also delete those tables and try reinstalling WPML.

Here is doc for more details:
https://wpml.org/faq/how-wpml-reset-works/

Thank you

The topic ‘[Closed] Error on activating WPML’ is closed to new replies.