Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Bruno Kos 2 weeks, 4 days ago.

Assigned support staff: Bruno Kos.

Author Posts
November 19, 2019 at 7:41 am #4968971

ibrahimK-3

While trying to add a new page and click publish,it shows saving while the page not get saved.
I got email with error:
WordPress version 5.3
Current theme: Rehub child theme - Rewise (version 9.0)
Current plugin: WPML Multilingual CMS (version 4.3.4-b.1)
PHP version 7.2.15

Error Details
=============
An error of type E_ERROR was caused in line 32 of the file /var/www/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php. Error message: Uncaught InvalidArgumentException: element_id and type do not match for element_id:1264 the database contains post_attachment while this function was called with post_page in /var/www/wp-content/plugins/sitepress-multilingual-cms/classes/core-abstract-classes/class-wpml-set-language.php:32
Stack trace:
#0 /var/www/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php(1497): WPML_Set_Language->set(1264, 'post_page', false, 'en', NULL, true)
#1 /var/www/wp-content/plugins/sitepress-multilingual-cms/inc/post-translation/wpml-post-translation.class.php(333): SitePress->set_element_language_details(1264, 'post_page', false, 'en', NULL)
#2 /var/www/wp-content/plugins/sitepress-multilingual-cms/inc/post-translation/wpml-post-translation.class.php(181): WPML_Post_Translation->maybe_set_elid(false, 'page', 'en', 1264, NULL)
#3 /var/www/wp-content/plugins/sitepress-multilingual-cms/inc/post-translation/wpml-admin-post-actions.class.php(115): WPML_Post_Translation->after_save_post(false, Array, 'en', NULL)
#

November 19, 2019 at 8:32 am #4969407

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Can you please check the previous private reply, which consists of our chat history and tell me if you were able to get this resolved?

Regards,
Bruno Kos