Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 44 replies, has 3 voices.

Last updated by Ahmed Ibrahim 7 months, 4 weeks ago.

Assigned support staff: Ahmed Ibrahim.

Author Posts
February 26, 2019 at 5:15 pm #3246443

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi, this is Ahmed Ibrahim from 2nd tier support team.

I was able to register your site using this link: hidden link
I did it using my WPML account, so I have removed it, and please try to register with the same link and let me know if it worked for you.

Best Regards.

February 26, 2019 at 11:44 pm #3247719

Puntorosso

Hi, I know I can register the site adding the /cms folder (even if the automatic WPML registration suggest without).
The problem is that if I try to update the plugin I get "Your subscription appears to no longer be valid. Please try to register again using a valid site key."

Here a screencast

hidden link

Thanks

Best

February 27, 2019 at 3:06 pm #3250998

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for the update, I was trying to replicate the issue on my local server, but I couldn't, so we will do some more investigations and will update you here.

Best Regards.

February 27, 2019 at 3:44 pm #3251250

Puntorosso

Ok, thanks.

Best

March 4, 2019 at 3:20 pm #3269531

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Can you please delete the old site keys from your account, and try again to register your site using this URL: hidden link, and let me know if it worked.

Best Regards.

March 4, 2019 at 4:09 pm #3269791

Puntorosso

Hi,
No, it doesn't.

hidden link

Best

March 4, 2019 at 6:49 pm #3270402

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Thanks for the information, I will check with our systems team, and come back to you.

Best Regards.

March 5, 2019 at 3:39 pm #3274897

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

We are trying to replicate the same issue on a clean installation in order to debug it, so we need your help to create the same setup as you, so can you please let me know the steps that you took to change your back-end URL to have /wp/ before the wp-admin

Best Regards.

March 5, 2019 at 5:06 pm #3275412

Puntorosso

Hi,
you mean the /cms/wp-admin , right?

I used a very common procedure to install WP in a subfolder.

The domain point to the standard "/public_html" folder.

1) I have installed WordPress in a subfolder "cms" (so in "public_html/cms")

2) In WP Settings page:
WordPress Address (URL): hidden link
Site Address (URL): hidden link

3) Copied index.php from the /cms subfolder to /public_html

4) Changed this line in the copied php file

require( dirname( __FILE__ ) . '/wp-blog-header.php' );

to

require( dirname( __FILE__ ) . '/cms/wp-blog-header.php' );

Thanks

Best

March 5, 2019 at 8:14 pm #3275984

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Thanks a lot for your help, I was able to replicate the issue using your steps and I will inform our developers to debug it and will update you soon I get their reply.

March 15, 2019 at 2:56 pm #3354841

Puntorosso

Hi, just wanted to check if there's some update on this.
Thanks

Best

March 15, 2019 at 3:54 pm #3355301

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

The issue has been escalated to our dev team queue, and they will fix it soon but I don't have the exact ETA for this, for now, I suggest you to update the plugin manually by downloading them from the our site: https://wpml.org/account/downloads/ and uploading them to your site, the steps are mentioned here: https://wpml.org/faq/install-wpml/

Best Regards.

March 15, 2019 at 4:10 pm #3355471

Puntorosso

Hi, I know that, but it's a nightmare.
I have 34 sites, with uploads restricted to 5mb, which means I would have to re-set the php.ini, delete the old WPML, upload the new WPML, set again the upload limit....an endless loop.

Or I have to set FTP accounts for all of them, or access cPanels....always a really long and tedious procedure.

By the way, this is not the first time I have to spend a day of work, just to update manually all my sites, because of a bug in a WPML update.

To be honest I am a bit sick of this.

Let's hope a better solution come out from the dev-team.

Thanks

Best

March 15, 2019 at 4:11 pm #3355473

Puntorosso

.... and just in case nobody else reported this, exactly the same problem happen with the Toolset plugins.

March 15, 2019 at 4:13 pm #3355479

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi, and sorry for any conveniences.

I will send your complaint to our dev team and will update you with any updates.

Best Regards.