This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Display Widget plugin does not work as expected.

Solution: The issue has been reported to the plugin other a few times: 1. https://strategy11.com/display-widgets/#comment-108 2. https://strategy11.com/display-widgets/#comment-123

This will take a lot of time to troubleshoot and to create the fix. And, spending sources on a discontinued plugin is meaningless.

This one is similar to Widget Logic if you want you can try: https://wordpress.org/plugins/widget-logic/

This topic contains 22 replies, has 2 voices.

Last updated by joseH-9 4 months, 4 weeks ago.

Assigned support staff: Riffaz.

Author Posts
May 13, 2019 at 7:32 am

joseH-9

Good morning, before installing WPML we worked without problem our side widget. Currently it does not work anymore, if we disable WPML, the sidebar shows us without problem. a greeting

May 13, 2019 at 9:02 am #3796293

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

I could not check your site. It goes to your site homepage if I go to your site login.

Could you please try this https://wpml.org/documentation/getting-started-guide/translating-widgets/displaying-different-widgets-for-different-languages/ and let me know how it goes.

Regards,
Riffaz.

May 13, 2019 at 10:03 am #3796715

joseH-9

Good afternoon, we have reviewed everything that comes in the article and there is no way to put it in widget. I have given access to FTP from Web company. It would be so kind to tell me the country from which you write me to add it to web company and so you can access. a greeting

May 13, 2019 at 10:27 am #3796933

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I am writing from Sri Lanka.

Regards,

May 13, 2019 at 10:46 am #3797163

joseH-9

Perfect, you can access without problem. a greeting

May 14, 2019 at 7:19 am #3804243

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I added a default WordPress widget hidden link to your sidebar and it works: hidden link
So the widget you are using hidden link is not compatible with WPML or it does not follow the default WordPress feature.

In this case, you can use the default WordPress text editor widget and copy the code you have and paste it in the text widget.

If you really want to use visual editor widget there we need to check this in a fresh installation.
We will find a workaround and let you know.

Let me know.

Regards,

May 14, 2019 at 7:50 am #3804419

joseH-9

Okay, we did it exactly as it was indicated and when selecting the pages where we want the widget to show us ... it fails again.

May 14, 2019 at 1:38 pm #3807373

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I just moved your content to text widgets and it works: hidden link
Do the same for other widget as well.
Hard clear your browser cache and check.

Regards,

May 14, 2019 at 2:10 pm #3807877

joseH-9

The problem is when you indicate the pages in which we want to appear, for example, we select "Show on checked pages" and then select the Blog pages, single post and most recent publications. When selecting the pages in which we want to appear is when it fails.

You appear because you leave it to appear on all pages, that's why you appear. But the problem is when you select the pages where you want the widget to be displayed.

May 15, 2019 at 5:45 am #3812405

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I understand now
So the options you are having / that specific widget/plugin is not compatible with WPML.

We need to check this in a fresh installation. So we can give you a workaround for this.

please,
1. go to hidden link
2. install your theme
3. configure the WPML as you have it on your site. at the last step just click next (site key)
4. create only one page/post
5. create the widget same as your in Appearance > widgets
6. assign it to the page you created.
7. recreate the issue.
8. let us know how to check this and how to recreate this issue.
9. explain the step 8 with screenshots and URLs for better understanding.

Regards,

May 15, 2019 at 6:47 am #3812631

joseH-9

Okay, could you give me FTP access? especially for the transfer of plugins. Thank you

The Country from which I write is Spain

May 15, 2019 at 7:30 am #3813119

joseH-9

I have already followed all the steps that you have indicated and it is already failing in the domain that you have indicated to me.

The problem is with the Display Widget plugin (this plugin is where we indicate the pages where we want the widget to show).

When we indicate the pages in which we want to show ...

May 15, 2019 at 7:42 am #3813239

joseH-9

Can you put the Spanish language back to us at hidden link?

May 15, 2019 at 9:03 am #3813947

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for this.

I escalated this to second tier.
The strange thing is when I selected the specific page for the widget it works in the test site.
you can login and check.

Also, it seems the plugin you are using is discontinued by it's author.

Anyhow, please be patient till we get back tp you again.

Can you put the Spanish language back to us at hidden link?
-
You can change your backend language from Users>Your Profile Language : hidden link

This select field will specify the language used for your backend. Please note that this will be only applied to the specific user account.

Regards,

May 15, 2019 at 9:15 am #3814161

joseH-9

In the widget that you have placed, you are not selecting "Show in checked pages" ... that's why it works for you.

We are aware that the plugin is not continued by the author, but it still works on all of our websites where we do not have WPML installed.

We are waiting for the solution.

a greeting