This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 28 replies, has 2 voices.

Last updated by Riffaz 5 months, 4 weeks ago.

Assigned support staff: Riffaz.

Author Posts
February 23, 2019 at 8:34 pm #3235711

nemesisZ

I am trying to: save settings

Link to a page where the issue can be seen:hidden link

I expected to see: changes saved successfully

Instead, I got:Error: data not saved

February 24, 2019 at 2:29 am #3235991

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Plugin conflict
Could you please disable all the plugins and check this?

Minimal Setup
If you disable all non-related WPML plugins, switch to one of the default themes like twenty seventeen, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Console Errors
In your chrome browser Press Ctrl + Shift + J (Windows / Linux) or Cmd + Opt + J (Mac) before you go to this step.
Check if you see any red errors here : hidden link and let me know.

Debugging
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see

If noting helps,
Could you please:
1. Make complete website and database backup of your site.
2. Download fresh copy of WPML and AddOns from https://wpml.org/account/downloads/
2. Install and test of our plugins if the issue persists
3. Let me know of the issue status

Regards,
Riffaz.

February 26, 2019 at 3:04 am #3242928

nemesisZ

Hello!
Responding to your suggestions:
1. I already try to disable all plugins not related to WPML and I still get the same error.
2. I already try to save the configuration using one of the default themes of WP and I still get the same problem.
3. I do not have console errors in the WP dashboard, even from the front-end.
4. At this moment I have debug mode enabled and no error appears in the WP dashboard and in the .log file there are only errors related to woocommerce:

[26-Feb-2019 02:55:52 UTC] PHP Notice: Undefined index: list_class in /home/rs3suyb0mbj5/public_html/wp-content/themes/inspiry-tourpress/woocommerce/cart/mini-cart.php on line 29
[26-Feb-2019 02:55:52 UTC] PHP Notice: Trying to get property 'post' of non-object in /home/rs3suyb0mbj5/public_html/wp-content/themes/inspiry-tourpress-child/woocommerce/single-product.php on line 482
[26-Feb-2019 02:55:52 UTC] PHP Notice: Trying to get property 'ID' of non-object in /home/rs3suyb0mbj5/public_html/wp-content/themes/inspiry-tourpress-child/woocommerce/single-product.php on line 482

5. I just downloaded the latest version of the WPML plugins and I still get the same error.

One more fact, I had already opened a ticket before because I had another problem related to the images in the secondary language, "Michael Kors" checked it and solved it. I also commented to him this error and he take a look, seeing that the problem was not so simple to solve, he told me to open a new ticket to focus only on this problem.

Let me know if you need access to the WP administrator to see the problem closely.

February 26, 2019 at 2:34 pm #3245464

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Thank you for letting know the details.

The errors you are seeing in error log is not WPML related.
Anyhow, disable your WooCommerce and check the issue again.
The errors are related to WooCommerce.

If you still have the problem it should be something related to your hosting configurations or settings.
Normally server related issues are not printed in error log files.
In that case, we have to check this in fresh, new hosting with your theme and plugins.
We will let you know how to do this once you get back to us after the one final test (WooCommerce).

Regards,

February 28, 2019 at 5:01 pm #3256702

nemesisZ

Hello, sorry for the loooooong wait, I've been too busy!
I try disabling woocommerce and all the plugins related to it and then save the changes, but I still get the same error (screenshot attached).
I think you should know that the site is hosted on a goDaddy hosting, the "Ultimate" to be exact.
hidden link

Let me know if you need anything more from me.

March 2, 2019 at 7:28 pm #3265130

nemesisZ

Hello! Any update on this thread? It has been 2 days since the last reply.

March 3, 2019 at 4:17 pm #3266433

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Sorry, I do not work on Fridays and Saturdays and I have to check this with the team.
Please be patient till I get back to you on Monday evening.

Regards,

March 6, 2019 at 6:58 pm #3281038

nemesisZ

Hello!
It is already half of the week, have you been able to check this thread?

March 7, 2019 at 5:03 am #3282352

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Sorry for the delay.

I am setting the next reply as private.
Let me know your site login details to check this closely.

Also, may install one or two plugin if need them to troubleshoot?

Regards,

March 7, 2019 at 7:58 pm #3286742

nemesisZ

The details of the login are not hidden. Hide them, please!
And if the plugins are going to help solve the problem, do it.

March 11, 2019 at 9:26 am #3309113

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I've sent this to our team to check internally.
Please be patient till we get back to you again.

Regards,
Riffaz.

March 11, 2019 at 10:32 am #3309729

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

This is fixed: hidden link

We turned off the string tracking and applied the ST recommend settings.
Please check and confirm.

Regards,

March 11, 2019 at 5:45 pm #3315401

nemesisZ

Ok, it seems that this error is no longer there, but I still have the same problem when saving configurations from here hidden link -translation.php & trop = 1

I'm following these steps https://wpml.org/documentation/getting-started-guide/translating-theme-options/, but I can not save the changes.

March 13, 2019 at 11:54 am #3332671

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I am unable to check that page.
I see just this when I go to that link: hidden link
Is the login user you gave not an admin user?
Could you please update it to admin?

March 13, 2019 at 11:56 am #3332713

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

did you mean this screen ? hidden link