This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Carlos Rojas 5 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
April 23, 2019 at 2:16 pm #3664569

stefanG-17

I am trying to: translate

Link to a page where the issue can be seen:hidden link

I expected to see:advanced editor

Instead, I got: Fatal error: Uncaught TypeError: Argument 1 passed to TranslationManagement::send_jobs() must be an instance of WPML_TM_Translation_Batch, array given, called in /home/tveiralf/public_html/onelife.is/wp-content/plugins/wpml-translation-management/classes/class-wpml-translation-job-factory.php on line 91 and defined in /home/tveiralf/public_html/onelife.is/wp-content/plugins/sitepress-multilingual-cms/inc/translation-management/translation-management.class.php:1157 Stack trace: #0 /home/tveiralf/public_html/onelife.is/wp-content/plugins/wpml-translation-management/classes/class-wpml-translation-job-factory.php(91): TranslationManagement->send_jobs(Array) #1 /home/tveiralf/public_html/onelife.is/wp-content/plugins/wpml-translation-management/classes/class-wpml-translation-job-factory.php(55): WPML_Translation_Job_Factory->create_local_job('146', 'is', NULL) #2 /home/tveiralf/public_html/onelife.is/wp-content/plugins/wpml-translation-management/classes/menu/translation-queue/class-wpml-translations-queue.php(529): WPML_Trans in /home/tveiralf/public_html/onelife.is/wp-content/plugins/sitepress-multilingual-cms/inc/translation-management/translation-management.class.php on line 1157

April 23, 2019 at 6:34 pm #3666947

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to follow this steps:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes, specially WPML plugins. Outdated functionalities can cause conflicts in the code.
- Flush any cache memory that might exist.
- Go to WPML -> Settings -> How to translate page and posts -> Select 'Classic Translation Editor' -> Translate the page where you see the issue -> Save the changes -> Activate the 'Advance Translation Editor' again.

Could you tell me if the issue persists?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos