This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.82 hours from now. Thank you for your understanding.

This topic contains 13 replies, has 10 voices.

Last updated by Vincenzo 7 months, 1 week ago.

Assigned support staff: Vincenzo.

Author Posts
February 8, 2019 at 9:29 am #3173844

marcoW-2

When trying to update the plugins "translation management", "String translation" and "Sticky links" I get the following error:

(PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature)

I already tried ging to plugins - new - commercial to update from there, but that does give the exact same error.

What am I doing wrong?

February 8, 2019 at 10:32 am #3174463

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, thank you for contacting WPML Support!

Please try these steps:

- Go to Dashboard -> Updates
- Press the "Check Again" button
- Press the "Update" button at the bottom of the page

- Go to Plugins -> Add New -> Commercial
- Press the "Check for updates" button

- Go to https://wpml.org/account/sites/ look for your current key and erase it.
- Create a new one for your site.
- Go to Plugins -> Add New -> Commercial
- Click on the "Unregister WPML from this site" button
- Register WPML adding your new key.
- Try also disabling the "Keep wpml.org up-to-date about which theme and plugins I use" option

If that does not fix the issue you can manually update the plugins.
❌ Before proceeding please make a full website backup! ❌
- Download the latest version of WPML from https://wpml.org/account/downloads/
- Disable WPML Multilingual CMS
- Delete WPML Multilingual CMS (the settings and the translations are saved in the database so they will not be deleted)
- Upload the freshly downloaded WPML plugin from Plugins -> Add New -> Upload Plugin
- Activate WPML

Please let me know if this solves the issue or if you need further details.

Thank you

February 9, 2019 at 1:05 pm #3178456

anastasiaM

This is preposterous. I cannot update like this for 10 sites. It is impossible. Please fix so I can update with managewp desktop

February 10, 2019 at 3:54 am #3179281

leandroP-2

Try disabling the plugins, updating them while disabled, then enabling them again. That worked for me.

February 11, 2019 at 7:20 am #3181048

Rhys Gregory

I've updated to the latest version, but I can no longer add any news posts to the website. I can go in and use the editor on existing posts, but adding a new post gives me a blank page/error. If I disable the plugin, WPML Multilingual CMS, it works... so I've now temporarily (I hope), disabled the plugin.

February 11, 2019 at 8:44 am #3181437

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

@anastasiam the steps required to solve on most of the cases are just these:
- Go to Dashboard -> Updates
- Press the "Check Again" button
- Press the "Update" button at the bottom of the page

@Rhys Gregory please open a new ticket about it and add the WordPress debug details:
- https://wpml.org/documentation/support/debugging-wpml/
You can open a new ticket from here: https://wpml.org/forums/forum/english-support/
This helps us to bring you a better service and also help other users with similar problems to find solutions when searching the forum.

Thank you

February 11, 2019 at 1:42 pm #3183141

urteP

Hi there, i updated my site at:
hidden link

and i am facing major problems.
The translated english homepage do not show any media.
hidden link
Same at the agency webiste:
hidden link

In the project (porftfolio) pages

hidden link

Only the first image in the top slider are shown.
LIek here:
hidden link

Can anybody help me please?
Thanx

February 11, 2019 at 1:45 pm #3183145

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

@urtep

Please open a new ticket with all the details on our forum.
https://wpml.org/forums/forum/english-support/

Thank you

February 11, 2019 at 1:45 pm #3183148

frankN-12

i have same issue, tried 10 times ur recomenndations, and sure i will not do all manually, i expect that you fix such issues, also afraid that such things happens like Gregory says, we dont have the time to solve ur misstakes, thanks for understanding, me laos ha sto do it on 8 pages, no time for only such small updates....thanks for understanding and hope you solve it...or i use poedit in future, thanks.

February 11, 2019 at 1:58 pm #3183196

urteP

Thank you Vincenzo, so i did. Since 3,5 hours nobody is answering and my site is down.

February 11, 2019 at 2:54 pm #3183600

Juliana Daltin

I followed directions! But nothing to do! I hope to resolve as soon as possible

February 13, 2019 at 8:29 am #3192538

boW-2

Hello
I have the same problem and followed the suggested steps but the problem persist.
You (WPML) must solve this problem as it's obviously affecting lots of people.
Regards
Bo

February 13, 2019 at 11:28 am #3193569

hopV

I am trying to: update

Link to a page where the issue can be seen: as the uploaded images

I expected to see: it up to date

Instead, I got: error

Can you help me, please?
Steve

February 14, 2019 at 8:58 am #3198290

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

we updated our plugins.

If the update issue persists, please try these steps:
- Download the latest version of WPML Multilingual CMS from our Downloads page.
- Disable and remove the main WPML plugin (WPML Multilingual CMS)
- Do a first-time install of the main plugin: https://wpml.org/faq/install-wpml/#first-install
- Go to Dashboard -> Updates
- Press the "Check Again" button
- Update the other plugins

Please let me know if this solves the issue or if you need further details.

Thank you