This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 27 replies, has 2 voices.

Last updated by T4ng 11 months, 2 weeks ago.

Assigned support staff: Lauren.

Author Posts
June 3, 2019 at 1:41 pm #3942955

T4ng

Hi Lauren,

You guys still couldn't reproduce it on the dev version? Is there a release planned?

Thanks!

June 3, 2019 at 3:51 pm #3943993

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

With the dev version (which will be released in the near future, although I don't have a release date) the text stays translated, but i found some problems with the media translation. So they are working through that now, and hopefully all will be resolved and a new version will be available soon. I'll keep you posted here, and once the beta version is available, you can try testing that on a staging site if you like.

June 11, 2019 at 4:15 pm #3997151

T4ng

Hi Lauren,
Just saw that 4.2.7 version had been released.

Does it solve our problem, and the media translations issues you found (I noticed problems as well, not getting some meta informations saved)?

Thanks

June 12, 2019 at 7:41 pm #4007379

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Yes, the latest releases should resolve the issue. Please make sure you update and have active WPML core, String Translation and Translation Management. Please let me know the results.

June 13, 2019 at 9:21 am #4010983

T4ng

Sounds like there's an issue with that release:
https://wpml.org/forums/topic/wpml-multilingual-cms-version-update-4-2-7-crashes-our-
website/
I might wait a bit for a stable release.

June 13, 2019 at 1:02 pm #4013083

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

There were a handful of clients that ran into issues, but not an overall bug. If you have a staging site, you can test there first. Otherwise, if you prefer to wait, just let me know how it goes once you update. Thanks!

July 5, 2019 at 12:33 pm #4151337

T4ng

We will try update WPML this month. Thanks for waiting closing this topic.

July 8, 2019 at 1:18 pm #4162765

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Sounds good, just let me know once you are able to update and if it resolves the issue.

July 15, 2019 at 7:27 am #4207833

T4ng

Thanks

July 15, 2019 at 1:49 pm #4211849

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Have you tested with the latest release? Please let me know if the latest version resolves the issue. Thanks!

July 15, 2019 at 7:56 pm #4214443

T4ng

I'd like to give it a try this week, but I just noticed the 4.7.2.1 update is not offered anymore from the plugin WP admin page. Is it no longer a stable release?

July 16, 2019 at 3:13 pm #4221621

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

It is still a stable release. You can go to Plugins -> Add New and click on the Commercial tab and update it from there.

July 30, 2019 at 8:44 am #4305825

T4ng

Lauren.
Indeed, the new release solves the issue : I can update the translated version of media already added to a page translation. It won't break the page.
However... I can't translate a newly created Elementor page anymore without breaking the whole layout in the translated version. I already faced this issue a couple of months ago, and used to fix it by setting _elementor_data translation values. It's not available anymore.

Major issue then...