This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Riffaz 1 month, 2 weeks ago.

Assigned support staff: Riffaz.

Author Posts
September 5, 2019 at 1:26 am #4514467

maryanneg

Hi Support,

I was trying to change the user's language setting from English to Japanese, but the menu doesn't have any changes. However when i deactivate the plugin "WPML Multilingual CMS", the language changes reflected immediately.

September 5, 2019 at 3:35 am #4515191

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

You are trying to change the language in in user > profile > language , right?

IF yes,

I could be able to fix this same issue for many other user as follow:

Please try this:
1. go to WPML > Theme and plugins localization
2. select the option "Translate themes and plugins using WPML's String Translation and always load .mo files as backup" in localization option : hidden link
3. save
4. switch back to "Translate themes and plugins using WPML's String Translation only (don't load .mo files)"

Your issue should be fixed.

This worked and solved two other tickets with the same issue.
i. https://wpml.org/forums/topic/woocommerce-not-translated-backend-in-english-not-italian-as-expected/
ii. https://wpml.org/forums/topic/default-site-language-is-not-working-its-set-to-slovak-but-everything-is-in-en/

Let me know how it goes.

Regards,
Riffaz.

September 5, 2019 at 5:00 am #4515451

maryanneg

Yes, but we cannot find the WPML icon in our menu.

September 5, 2019 at 5:04 am #4515483

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

What? that is very strange.
Then how you are translating the pages and posts and changing settings for WPML/translations?

Are you checking while the WPML active?

Regards,

September 5, 2019 at 5:18 am #4515489

maryanneg

Thank you for the quick response.
We active the WPML plugin and tried to follow the above instructions.
When we changed to "Translate themes and plugins using WPML's String Translation and always load .mo files as backup",
everything seems going well and the language setting reflected immediately .
But after I switch it back to "Translate themes and plugins using WPML's String Translation only (don't load .mo files)", it doesn't work again.

September 5, 2019 at 5:20 am #4515493

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

You are welcome.

You can keep the first setting then.
No need to switch back.

Let me know if you need anything else regarding this.

Regards,