This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Riffaz 6 months, 1 week ago.

Assigned support staff: Riffaz.

Author Posts
April 7, 2019 at 2:40 pm #3552181

yunfeiS

I am trying to: modify the Localization options in the Theme and plugins localization tab
Instead, I got: "Error:Data not save"

When I tried to set the Localization options, clicked the save button, it prompted that "Error:Data not save"

I tried after disabed all pluging except wpml, It didn't work. And I use mysql5.7

April 7, 2019 at 2:58 pm #3552229

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Console Errors
In your chrome browser Press Ctrl + Shift + J (Windows / Linux) or Cmd + Opt + J (Mac) before you go to this step.
Check if you see any red errors here : hidden link and let me know.

Debugging
1. Please follow the debugging information provided here: https://wpml.org/documentation/support/debugging-wpml/#enabling-the-built-in-debugging-feature-in-wordpress.
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see

Let me know.

Regards,
Riffaz.

April 7, 2019 at 3:27 pm #3552263

yunfeiS

I am using Maxthon browser.
After I enabled the debug, and triged the action, there isn't any new update in the debug.log

April 10, 2019 at 4:50 pm #3578931

yunfeiS

It didn't need to set the database username and related password in this migration plugin.
The copying action is goin on.
Pls kindly check it.

April 11, 2019 at 3:22 am #3583259

yunfeiS

It's done. You could test on it.

April 11, 2019 at 7:00 am #3584259

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

The migration is success: hidden link
Thanks for this.

We need to login to check this.
The login details are same as your site.

The next reply is set to private.

Regards,

April 11, 2019 at 7:01 am #3584261

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

The migration is success: hidden link
Thanks for this.

We need to login to check this.
The login details are same as your site.

The next reply is set to private.

Regards,

April 14, 2019 at 9:10 am #3607303

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I was checking the site and it suddenly went to 500 internal error.
I need to check this with our server team.
I'll write you back on Monday evening.

Regards,

April 15, 2019 at 7:32 am #3610523

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I escalated this to our second tier support.
Please be patient till we get back to you.

Regards,

April 15, 2019 at 7:52 am #3610653

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

That was happening due to stuck nonce : hidden link

The solution:
if we remove the key "wpml_notices" in the wp_options table and refresh the page and then try again it works.

If you re not sure how to remove that key in your database let us know.

We strongly suggest you to take a full backup of your site before proceeding this.

Regards,

April 16, 2019 at 10:34 am #3620983

yunfeiS

I didn't found the key "wpml_notices" in the wp_options table.
How did you found it, maybe I don't know the way as you did.
Thamks

April 18, 2019 at 11:02 am #3638611

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Please back up your database.

And run this query:

SELECT * FROM 'wp_options' WHERE 'option_name' LIKE '%wpml_notices%'

You will find it.
Delete it and check.

Let me know how it goes.

Regards,

April 18, 2019 at 4:12 pm #3640701

yunfeiS

It didn't work as this:

mysql> SELECT * FROM 'wp_options' WHERE 'option_name' LIKE '%wpml_notices%';
ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''wp_options' WHERE 'option_name' LIKE '%wpml_notices%'' at line 1
mysql>

April 19, 2019 at 6:45 am #3643747

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I am setting the next reply as private.
Let me know your FTP / cPanel details to check this closely.

Regards,

The topic ‘[Closed] "Error:Data not save" when tried to modify the Localization options’ is closed to new replies.