This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 31 replies, has 2 voices.

Last updated by Marco 2 months, 3 weeks ago.

Assigned support staff: Yvette.

Author Posts
June 26, 2019 at 12:17 pm

Marco

hey guys

the problem mentioned in my previously closed ticket
https://wpml.org/forums/topic/errors-404-generated-by-wpml-although-the-content-exists/

is still there, and the site is down in English, again 🙁

The hosting provider reports the following:

AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace

Alejandro's latest response was the following:

After many tests ran, i found out the cause of the issue was a connection between custom post types plugin (by your theme) + ACF - ACF Multilingual.

The only thing missing was our ACF Multilingual plugin. ACF must be doing something to the custom post type, because it wouldn't have created this issue.

I spotted the problem because i understood the portfolio item in English actually worked but ONLY when the English language was active in the backend! so only one version worked at a time.

I already downloaded and activated ACF Multilingual and now everything seems to work.

Please check and let me know.

Question is: how do I get rid of this error, which is caused by "too many redirects"?

there is actually no redirection plugin nor htaccess rules.

Where does this come from?

thanks for checking again
Marco

June 26, 2019 at 5:54 pm #4094459

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Thank you for access to your site. Here are my observations.

1. Anytime I edit a portfolio and save, the 500 error or the 404 error will happen.
If I edit and save the IT version, the EN will mostly fall in 404 error
If I edit and save the EN version, the EN and IT portfolio will go into 500 error

2. I am forced to regenerate permalinks to be able to view the portfolios again

So, in short, the error is easily reproduced by editing the portfolio in either language. Do you agree with this observation?

Next steps:

1. Send me a copy of your site as per this document:
https://wpml.org/faq/provide-supporters-copy-site/
You can filter out the wp-content/uploads directory if your site is very large

2. I will install this on my local serer and confirm that the problem still exists even in a minimal setup (i.e. standard theme and non-WPML plugins deactivated)

I am opening the private area for your Duplicator package. Please upload the actual package to a file sharing service and only include a downloadable link in your next reply.

June 27, 2019 at 8:24 am
June 28, 2019 at 10:05 am #4106353

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

1. ACF Pro Plugin
I did quite a bit of testing on my local copy of your site. What I have found is that the problem is linked to the theme and the ACF Pro plugin. When I deactivate the ACF Pro Plugin, and execute the steps I outlined to provoke the issue, the redirects do not happen.

I can see that the version of ACF Pro delivered by your theme needs updating. So, please first try updating this plugin and confirming that the problem still exists.

Then, please write back with a zip copy of the folder:
wp-contents/plugins/advanced-custom-fields-pro

I can then install that on my local server.

2. Theme incompatibility - Soprano
It may also be linked to this code that I found in the functions.php of your theme´s internal plugin: "Soprano Theme- Custom Post Types". There seems to be a flush of the rewrite rules happening when the slugs are not matching after edit. Perhaps this is why the problem is fixed by regenerating the rewrite rules when the issue happens.

Once we eliminate the possibility of the ACF Pro plugin needing upgrading, we can then send the theme to our compatibility team for more investigation.

June 28, 2019 at 10:41 am #4106663

Marco

Dear Yvette,

thank you so much for your precious support and for digging into this matter so thoroughly

I've updated their required plugins and yet the issue persists 🙁

Sorry for that, I assume you should get back to the compatibility team for more investigation...

Please keep me posted.

thanks for now, wish you a good rest of the day

June 28, 2019 at 12:39 pm #4107429

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Unfortunately, as this is a "new" theme for WPML to study, I am required to replicate the problem on a new installation.

I have prepared a sandbox site for you here:
hidden link

Please
1. Upload your theme
2. Do the minimum configuration required to create 1 portfolio and its translation
3.Confirm that you can replicate the error by doing the following steps
3.1 Modify the primarly language portfolio
3.2 Attempt to view the 2nd language translation - does a 404 show up?

Please write back when you are done

July 1, 2019 at 9:59 am #4117637

Marco

hey Yvette

I tried to replicate the problem and have setup the theme and WPML (probably) the same way I have it on my instance

Did the following test portfolio item:

ITA (main)
hidden link

ENG:
hidden link

only difference I see is
hidden link

but I can't make the error 500 or 404 for the too many redirects appear... 🙁

July 1, 2019 at 11:17 am #4118229

Marco

x

July 1, 2019 at 12:43 pm #4118991

Marco

this is what the dev at soprano wrote me:

Also about Custom Post Type plugin - it flushes rewrite cache only when you change CPT slug in theme options. So if you never changed it - the plugin did not flushed rewrite cache.

I've just replied:

hi Roman

I've installed the ACF PRO again (you can never know) following ur link but still the issue appears.

for the CPType, yes I've changed it from PORTFOLIO to PRODOTTI which is more suitable for the site.

So yes, it flushes the rewrite cache

How can I fix it and have the site working with Soprano?

thanks
July 1, 2019 at 1:06 pm #4119221

Marco

One more, which can be probably helpful:

Hi,

There is no any issue in that fact the plugin flushed the rewrite cache once. It is a common task which can't break your site. This is just for clarification. CPT plugin can't break the site. Soprano theme was sold for over 1000 times and no one from our other customers has reported about same issues.

So it would be great if you send this information to WPML support and ask them to inspect deeper. I think the bug is somewhere between ACF PRO and WPML. Both plugins are very popular so any issues should be fixed.

Thanks for having a look at it

July 1, 2019 at 3:55 pm #4121041

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Thanks for trying to replicate this on the Sandbox site.

If you were unable to replicate the issue, then this means the problem is not compatibility related but something more to do with your installation.

I have reclassified the escalated ticket to be our 2nd tier support. Let´s see what they can find out.

July 1, 2019 at 4:02 pm #4121087

Marco

🙁 that's a pain, I truly hope they'll let me out of this embarassing situation 🙁

thanks for the moment, waiting for your feedback!

July 4, 2019 at 2:43 pm #4144643

Marco

hi guys
do you have any feedback on this? 🙁
thanks

July 9, 2019 at 7:08 am #4167923

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I´m sorry for the delay to respond - let me check on that for you.

July 11, 2019 at 1:25 pm #4190095

Marco

Still nothing on your end? 🙁