This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by Itamar 1 year ago.

Assigned support staff: Itamar.

Author Posts
September 14, 2018 at 11:07 am

ramonaB

Once the plugin is activated the following errors appeared after the custom permalinks selected:

Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in /vhosts/p2h/bergepur/wp-includes/class-wp.php on line 218

Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in /vhosts/p2h/bergepur/wp-includes/class-wp.php on line 219

Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in /vhosts/p2h/bergepur/wp-includes/class-wp.php on line 218

Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in /vhosts/p2h/bergepur/wp-includes/class-wp.php on line 219

Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in /vhosts/p2h/bergepur/wp-includes/class-wp.php on line 218

Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in /vhosts/p2h/bergepur/wp-includes/class-wp.php on line 219

Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in /vhosts/p2h/bergepur/wp-includes/class-wp.php on line 218

Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in /vhosts/p2h/bergepur/wp-includes/class-wp.php on line 219

Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in /vhosts/p2h/bergepur/wp-includes/class-wp.php on line 218

Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in /vhosts/p2h/bergepur/wp-includes/class-wp.php on line 219

Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in /vhosts/p2h/bergepur/wp-includes/class-wp.php on line 218

Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in /vhosts/p2h/bergepur/wp-includes/class-wp.php on line 219

Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in /vhosts/p2h/bergepur/wp-includes/class-wp.php on line 218

Warning: preg_match(): Compilation failed: nothing to repeat at offset 1 in /vhosts/p2h/bergepur/wp-includes/class-wp.php on line 219

September 14, 2018 at 12:39 pm #2735341

ramonaB

Looks look the errors come from this plugin WPML String Translation

September 16, 2018 at 8:34 pm #2739181

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Could you please specify what is the custom permalink that you are selecting?

Also, by looking at the debug info that you have attached I can see that your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.3 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above(this OK with your installation).
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

Could you please perform those procedures and see if it help?

Regards,
Itamar.

September 17, 2018 at 12:02 pm #2740774

ramonaB

We raised the WP Memory Limit to 256M and still see the errors. Right now the 'Day and name' permalink is set, however all the permalinks (hidden link) except Plain call the errors.

September 18, 2018 at 5:33 am #2743610

ramonaB

Any news on my request?

September 18, 2018 at 8:42 am #2744055

ramonaB

I there! Itamar, I understand that you might be very busy, however I have to go live and the site is down. Still no reply for 24hours already. I desperately need your help to solve this issue.

September 18, 2018 at 3:17 pm #2745646

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and sorry for the late reply and thank you for following my suggestions.

I wanted to check things on your site but there are server credentials that need to be filled and you have not shared those credentials with me. Please see the attached screenshot. You have only shared the WordPress and FTP credentials. You are writing that it looks like the errors are coming from Strings Translation.
Could you please tell me how have you reached this conclusion?
Looking at the errors I can not see how they are related to WPML.
Where do you get those errors show?
Is there another problem that is being caused by those errors or is the issue only about the errors showing?

I'll enable private message for the next reply so you can share with me all the details that I need to see the issue on your site.

Regards,
Itamar.

September 18, 2018 at 7:58 pm
September 19, 2018 at 11:06 am #2748534

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Yes, the .htaccess details were missing. Thanks for sharing them and sorry for not uploading the screenshot.

I've accessed your site and could see the errors. To be able to see them I've also accessed your site with FTP and in the wp-config file enabled the option to see errors. Then I've deactivated WPML, and the Strings Translation plugins and still, the errors were showing. Please see the following link to a recording that I've made that shows that. hidden link
So I think that you have reached a wrong conclusion that those errors are showing because of WPMl and Strings Translation.

Can you now agree with me on this issue?

Best Regards,
Itamar.

The topic ‘[Closed] Errors with the permalinks’ is closed to new replies.