This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Mihai Apetrei 12 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
October 12, 2018 at 7:36 am

grahamH-3

I am trying to: show an essential grid of my custom post type 'videos'

Link to a page where the issue can be seen: Our translation is not available to the public yet. Here is a video to show you: hidden link

I expected to see: the grid

Instead, I got: nothing

Duplicator failed for me, I've given you by updraft backups if you need them.

Grid works
hidden link

Same grid doesn't work:
hidden link

My goal is to get a similar grid to show on the spanish (and other translations) homepage:
hidden link

You could try logging into the staging site, I'm hoping it will be working by the time you have access: hidden link

October 15, 2018 at 12:27 pm #2817386

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

First of all, thank you very much for the detailed video explaining what's going wrong and what you actually need help with.

In order to be able to access your backend and go forward with a deeper debugging session, I would need to be able to actually log in.

It seems that for the moment there's a 2 step authentication method and I'm really not able to log into the backend of the site (I will be also attaching a screenshot here so that you can see what I mean).

Can you disable the 2-step authentication for the moment or find a way for me to log in?

I will be waiting for your reply.

October 16, 2018 at 12:34 am #2818999

grahamH-3

Oh sorry. I've disabled two factor on both the live and staging site. Let me know if you need anything else from me.

October 17, 2018 at 10:27 am #2824215

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

There are 2 differences that I can see right off the bat between the page where the grid shows up (hidden link) and the other 2 pages.

Difference number 1:

- on the first page I can see that this shortcode is used:
[ess_grid alias="membership"][/ess_grid]
- while on the other 2 pages, this shortcode is used:
[ess_grid alias="grid-1"][/ess_grid]

There is a possibility that there's a setup issue with "grid-1" but "membership" might work. Please test with that.

Difference number 2:

- on the first page, the shortcode is existing in a text module of its own without having any other content added in the same text module
- while on the other 2 pages, the shortcode is added in the same text module where we already have the content section title (LATEST VIDEOS/ÚLTIMOS VIDEOS).

Please create a new text module under the existing text module that contains the title and add the shortcode there by its own.

Please let me know if any of these options worked.

It is also important to mention that The Essential Grid plugin is not officially compatible with WPML if we search for it here:
https://wpml.org/documentation/plugins-compatibility/

I'd suggest you contact the plugin authors and recommend them to join our 'Go Global' program (https://wpml.org/documentation/theme-compatibility/go-global-program/) where our Compatibility developers will help them make their plugin 100% compatible with WPML for free.

As a workaround, you can try to create a different grid per language.
Once you created the translated grid, you can use the shortcode of the translated grid in the translated page/product.

Please let me know if this solved your issue or if you still need help.

I will be waiting for your response.

Kind regards,
Mihai

October 19, 2018 at 7:48 am #2830944

grahamH-3

I have tried as you said to make the shortcode in its own text module.
As you can see here:
I have created this test page which includes both an essential grid and a 'the grid' shortcode (which supposedly is supported). Both don't show on the Korean version:
hidden link
Whereas on the english version both show:
hidden link

Are we missing something in the settings of how these should be set up?

I should say, we don't actually care too much if the grid is not translasted, we just want the actual grid to show. If it shows in English that is totally fine.

October 19, 2018 at 3:37 pm #2832595

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

After some deeper analyzation, from what I can see, the essential grid is actually displaying content that is taken from the custom post type called "Videos".

If you go on the English "Videos" page in the backend WordPress panel (hidden link) you can see there are videos added but if you go into the Korean version of that page (hidden link) you will see there are no videos so I think Essential Grid doesn't find any content to display due to the fact that the video posts are not translated.

Please go here (hidden link) and click the "+" to translate the post videos into Korean for example, then save the video post in that language.

You should now be able to see that video on the Korean homepage if you are using the shortcode of the Essential Grid called "Home Membership": [ess_grid alias="grid-1"][/ess_grid]

Please let me know if this solved your issue or if you still need help.

I will be waiting for your response.

Kind regards,
Mihai