This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Events Calendar list widget URL missing slash

Solution: I still don't know why the events slug was getting the slash removed (only happened after installing WPML), but I intended to remove 'index.php' from the links anyway, and this fixed the problem.

Relevant Documentation:

This topic contains 8 replies, has 2 voices.

Last updated by Carlos Rojas 4 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 26, 2019 at 8:43 pm #3892425

cxhristopherL

I am trying to: fix this issue that appeared after installing WPML

Link to a page where the issue can be seen:
I cannot provide a link without creating a login to the site because I'm redirecting all traffic unless user is logged in. I can create an account for you to use if needed.

I expected to see:
hidden link

Instead, I got:
hidden link

May 27, 2019 at 9:04 am #3895005

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I can see in the URL provided the 'index.php': could you tell me if you are using any kind of special configuration to obtain this URL?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

May 27, 2019 at 2:13 pm #3898161

cxhristopherL

This issue is appearing in the Events List widget for Events Calendar Pro, but only in the Czech version. The English version (default language) of the widget is correct. I already tried resetting slugs, but the problem persists.

There is an URL at the bottom which links to the posts page, and I cannot find anywhere to configure other than the Events URL slug configuration in Events->Settings, and this is correct.

Images of slug config and widget config attached.

Please send me your email address if you want to view on the site.

Regards,
Chris

May 28, 2019 at 8:07 am #3903775

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Chris,
Thank you for your message.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Regards,
Carlos

May 28, 2019 at 7:33 pm #3909783

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Chris,
Thank you very much for the information provided.

Before we continue I need to ask you to increase the memory limit by following the steps described in my previous message ( #3895005 ).

Also, please contact your hosting providers and ask them to activate the 'Multibyte String extension'. If you go to WPML -> Support you will see the warning message.

Please let me know when if the issue persists after increasing the memory limit and activating the mentioned extension.

Regards,
Carlos

May 28, 2019 at 11:50 pm #3910535

cxhristopherL

Hi Carlos,

I'm running this instance in a cloud container, so I am the server admin...

I fixed both issues, updated my OS including PHP version, and restarted apache. Please let me know what you find now that I "restarted the computer" 🙂

Best,
Chris

May 29, 2019 at 10:22 am #3914161

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Chris,
Thank you very much for your udpate.

I visited the site and the link with the issue, however I can't find where this link is coming from, I can't find the widget in the frontend.

Could you attach some screenshots and describe the steps to reproduce the issue so I can have a better understanding?

Also, could you tell me why there is an 'index.php' in the URL?

Regards,
Carlos

May 29, 2019 at 1:21 pm #3915857

cxhristopherL

Thanks Carlos,

I still don't know why the events slug was getting the slash removed (only happened after installing WPML), but I intended to remove 'index.php' from the links anyway, and this fixed the problem.

Take care,
Chris

May 29, 2019 at 2:37 pm #3916451

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Chris,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos