This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by antonieP-3 3 months, 2 weeks ago.

Assigned support staff: Yvette.

Author Posts
July 2, 2019 at 12:31 pm #4126749

antonieP-3

Hello dear support crew,

another problem has been occured. I am very sorry for contacting you again, but I couldn't find a good solution on my own until now.

The Events Calendar uses for not translated strings in the non-default language version in the front end the ENGLISH strings, even though the default language for my site is German and I don't use English as an additional language.

Only for the setup I had to add English as additional language (without needing it), but deleted it right after that.

Is there a way to tell The Events Calendar to use German as default language when there is no string translation? Did I set up something wrong?

You can see this:
In the sidebar and in the events view and in the screenshots of the string table.

What I tried:
I read related support tickets, already enabled the AJAX Cookie Option and the "clean up" option under "troubleshooting".

I add some screenshots of the string table and the settings I use.

Thank you very much for having a look at this.
Antonie Preikschas

July 2, 2019 at 4:40 pm #4128807

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

The site will show English strings if it is not able to find a German translation. The highlighted yellow German values are being read from the existing .mo files on your installation.

Please try changing your setting for
WPML > Theme and plugins localization > Localization options > How to translate strings in themes and plugins?

To ge the second option : "Translate themes and plugins using WPML's String Translation and always load .mo files as backup"

If this does not work please write back with system access details and steps to see a string that does not translate as expected on front end.

Thanks

July 3, 2019 at 6:12 am #4132107

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Thank you for the system access. Unfortunately, the userid you provided does not have administrator priveleges so I cannot do anything in the backend. I can only see my user profile.

Could you please change the profile type to admin and then notify me when this is done?

Thanks

July 3, 2019 at 7:08 am #4132501

antonieP-3

Hello
and sorry for this. I changed it to admin.

July 3, 2019 at 11:23 am #4135391

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Thank you.

So, you should understand that the source language of the strings is always going to be "English" because this is the language of the plugin/theme. e.g. if you look at the PHP files, this is the string that is found.

In the case that you would like to have the German translations appear as the "default", you can load the DE .po file as the translations of the fri_DE locale using the WPML > String Translation > import/export .po tool

I did this for you and your event is now appearing as you expect.
I hope this resolves the issue for you.

July 3, 2019 at 12:52 pm #4136531

antonieP-3

My issue is resolved now. Thank you!