Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 42 replies, has 3 voices.

Last updated by Johan 1 year, 3 months ago.

Assisted by: Johan.

Author Posts
December 28, 2022 at 3:22 pm #12723553

damienB-8

We are using £Phlox Pro as the main theme for our website. We updated both versions of Phlox Pro and WPML but every time we activate WPML we have a critical error

December 28, 2022 at 4:45 pm #12724095

Nicolas Viallet
Supporter

Languages: English (English ) French (Français )

Timezone: America/Lima (GMT-05:00)

Hello again,

As discussed, once you rolled back a recent backup and your site is up and running again I will need to replicate it on our servers and run some tests.

For this, either your dev can install a plugin called “Duplicator” on your site. This will allow him to create a copy of your site and your content.
I have activated a private field for you where you can share those files (package + installer).
- He can exclude /wp-uploads from the copy to reduce the size
- Once the package is ready, if the files are too large to upload them to the private field, you can share a link to Google Drive, Dropbox, WeTransfer or any other similar service.

Or, you can provide me with a temporary admin access (wp-admin) and allow me to install Duplicator to take the copy myself. I will activate a private field for your next answer where you can provide that information safely (this field is only visible by you and the support team). Don't share your own admin account, create a new one that you will delete when we finish troubleshooting.

In both cases, once the problem is resolved I will delete the local site.
https://wpml.org/faq/provide-supporters-copy-site/

Nico

December 31, 2022 at 1:55 am #12734781

Nicolas Viallet
Supporter

Languages: English (English ) French (Français )

Timezone: America/Lima (GMT-05:00)

Hello,

Just a quick message to let you know that I managed to take o copy of your site.
I'll get back to you as soon as we find the issue and how to solve it.

December 31, 2022 at 2:15 am #12734801

Nicolas Viallet
Supporter

Languages: English (English ) French (Français )

Timezone: America/Lima (GMT-05:00)

Hi Again,

The first thing I wanted to try on this copy was minimal environment. For that I deactivated all your plugins and reactivated only WPML plugins. This worked (no critical error)!

Then I reactivated your plugins one by one in order to identify which plugin was creating a conflict with WPML. However I couldn't reproduce the issue. All plugins are now reactivated and I didn't get any critical error.

I even updated a translation and ran some WPML troubleshooting tools just to make sure that our plugin was working correctly.

Maybe I missed something? Could you please log into this copy site and try to reproduce the critical error? This only difference with your site is that the Phlox Pro licence is not activated, maybe you could try to activate it?
Here is the URL: hidden link
You can use the same credentials than your prod site

Nico

January 3, 2023 at 1:05 pm #12745105

damienB-8

Hello, my best wishes for the new year!
Thank you so much for looking into it, sorry I was off until today. .
I had a look at hidden link and activated the theme.
Some features of the theme are missing though - should I try to add them to see if it's still working?
I can see as well that elementor pro is not activated as well, and so some features are not displaying. should I try to activate it as well?
Also I can't see how to access the translated versions on hidden link - should I just add en to check?

January 3, 2023 at 6:20 pm #12747039

Nicolas Viallet
Supporter

Languages: English (English ) French (Français )

Timezone: America/Lima (GMT-05:00)

Hello,

Yes please feel free to activate and modify anything you need to reproduce the issue on that sandbox. Once the issue is reproduced we can investigate to identify the root cause.

On my side I have activated a footer selector to make sure you can navigate through your languages.

Nico

January 3, 2023 at 7:18 pm #12747231

damienB-8

Ok thanks.
So I activated everything and so far no critical error - lots of widgets and pictures missing but I guess we can repair this separately.
Should we try to update wordpress then?

January 4, 2023 at 12:59 pm #12751089

Nicolas Viallet
Supporter

Languages: English (English ) French (Français )

Timezone: America/Lima (GMT-05:00)

Hello,

I excluded the uploads folder (which has all your images) from the copy I took in order to reduce the size that's why all images are missing. It's not a bug.

So now, if you want to try on your production site let's follow those steps:
1. Make a full backup of your site and database
2. Activate WP_DEBUG in order to log any error
Access your server via FTP and open wp-config.php (in your WordPress root directory).
Insert those lines just before /* That's all, stop editing! Happy blogging. */

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

3. Deactivate all plugins
4. Update WPML and String Translation to the latest version and activate them.
You can download all our plugins directly from your WPML account.
- Go to https://wpml.org/account/downloads/
- Click on "Download WPML manually" to see all plugins and download them
- In your WP dashboard, go to "Plugins > Add new" and use the button at the top of your screen to upload the .zip file
5. Then reactivate your plugins one by one (or in small groups). This way you can verify at which point the issue appears again and identify the plugin that is causing the issue.
6. If the issue reappears during point #5, then access the debug log from WP_DEBUG here: /wp-content/debug.log and copy paste the info in your next answer.

Please keep me updated,
Nico

January 4, 2023 at 2:27 pm #12751675

damienB-8

Hi again, so I deactivated everything, then reactivated the theme related plug ins. Then reactivated WPML and got a critical error - I activated only WPML CMS, and didn't activate media or string translations as just WPML CMS gave the critical error.
I deactivated the theme and reactivated only WPML - same.
The log gives us plenty of errors linked with images like these:
[04-Jan-2023 14:11:11 UTC] Auxin_Aq_Resize.process() error: Image file does not exist (or is not an image): /home/unitecar/public_html/wp-content/uploads/2022/02/WhatsApp-Image-2022-02-03-at-10.14.22.jpeg - please see screenshot attached

My guess then is the error somehow comes between WPML and the images. When WPML is deactivated the images work fine on our website.

WhatsApp Image 2023-01-04 at 10.22.47.jpeg
January 4, 2023 at 2:36 pm #12751837

damienB-8

My developper confirms that we don't use an external image resizer so it seems that the issue may come from the theme's built in resizer - that's what he says: Auxin Image resizer is causing a critical error when WPML is activated because it states images don't exist

Have you encountered this before with the Phlox theme?

January 4, 2023 at 2:38 pm #12751839

damienB-8

Just adding the screenshot

WhatsApp Image 2023-01-04 at 10.33.20.jpeg
January 4, 2023 at 11:22 pm #12754931

Nicolas Viallet
Supporter

Languages: English (English ) French (Français )

Timezone: America/Lima (GMT-05:00)

Hi,

I think your dev find the issue. You see in order to allow you to translate all texts related to your images such as "ALTs" or "Captions", WPML create an new entry in the database. It doesn't duplicate physically the images (to avoid to fill up your server storage) but yes it will have a different database entry for each language for the same image.

Your theme is marked as compatible: https://wpml.org/theme/phlox/
Can I take another copy of your site (this time including the /uploads folder) to see if the issue is reproduced on sandbox?

If I can reproduce the issue then I will be able to escalate the case to the compatibility team.

Nico

January 5, 2023 at 2:06 pm #12758895

damienB-8

Hello yes please, you can make another copy.
We're also checking things on our side as to why this issue happened with images.
Let me know,

Maryline

January 6, 2023 at 4:04 pm #12765689

Nicolas Viallet
Supporter

Languages: English (English ) French (Français )

Timezone: America/Lima (GMT-05:00)

Hi,

I tried many times to download a new package. Everything seems to work but when I upload it on a new sandbox I have the following error:

The expected archive size is [888.61MB]. Currently the archive size is [200.27MB].

Can we try to reproduce the issue on the first sandbox (hidden link)?
Please try to upload some images in your post/pages and then translate them.

Nico

January 11, 2023 at 3:56 pm #12797121

damienB-8

Hello, so I tried to upload pictures but only a few as for some reason it takes a long time. I could not reproduce the error so far. So... maybe what we'll do is rename all pics on our side and see if when we reactivate WPML we still have the critical error. What do you think?

This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.