This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.14 hours from now. Thank you for your understanding.

This topic contains 11 replies, has 2 voices.

Last updated by Lauren 1 year ago.

Assigned support staff: Lauren.

Author Posts
October 5, 2018 at 4:42 pm #2791335

UT

I am trying to:
Edit links by using "Insert/edit link" pop-up in classic editor.
Link to a page where the issue can be seen:
in every page or post
I expected to see:
When I edit a link by using "Insert/edit link" pop-up; I expect that to see the page, post etc. from the right content of language. For example if I insert/edit a link on a TR post, the "Insert/edit link" pop-up should list the TR existing content.
Instead, I got:
Existing content reads the data form the default language only

Note: I tried the all basic steps such as clearing the cache and refreshing the permalink etc.
Note: It is new. I did not faced it until now.
Note: I don't know if it is related but: I added some extra codes to theme's wpml-config.xml file for Drift. (Which your team suggested earlier) I wanted to let you know.
<wpml-config>
        <admin-texts>
            <key name="copyright"/>
            <key name="Drift_settings">
                <key name="drift_enabled"/>
                <key name="drift_identified"/>
                <key name="drift_widget_code"/>
            </key>
        </admin-texts>
</wpml-config>

October 8, 2018 at 7:19 pm #2797150

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Please try temporarily disabling Sticky Links. Then, save your original page again. Now, when you try to add a link in the translated page, does it show the correct pages?

If not, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentyFifteen. With these settings, is the issue resolved?

October 9, 2018 at 9:37 pm #2802276

UT

Nope! I already tried that. Still same.

October 9, 2018 at 10:36 pm #2802313

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

October 10, 2018 at 7:51 pm #2805643

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for allowing me access. I wonder if his is happening because you have enabled "Auto Adjust IDs'. The WPBakery page builder content is meant to be translated via the page builder. If you disable this option from WPML -> Languages and clear your cache, what happens when you try to link to a page in the secondary language?

October 10, 2018 at 8:07 pm #2805693

UT

I tried. No luck. The weirdest part is it was working. No update, nothing, it decided to not to work.

October 10, 2018 at 8:10 pm #2805707

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

That is very strange that it used to work and now it is not. Did you change the default language of your site? For the next step, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentyFifteen. With these settings, is the issue resolved?

If you don't have a testing environment available and cannot test this on your live site, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to set up your site locally and run these tests for you.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply. I will also need the username and password of a user that was created before the duplicator package was created.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will enable the next reply to be private so only you and I have access to it. Thanks!

October 10, 2018 at 8:40 pm #2805765

UT

Hi Lauren, this is not possible to work on the production state. However, you can copy the files and test on your own (local).

October 10, 2018 at 8:46 pm #2805769

UT

Regarding your questions: Nope. Not any huge steps that I can mention. The only thing was editing the wpml-config.xml file but I tried to rollback (I already mentioned that at the ticket). It is not related that.

Actually, I thought that you already faced and fixed that kind issues, this is why I created this ticket. I don't want to follow the rookie steps here with you such as disabling the plugins etc. If you faced that already and if you have any solution, thats fine, please share me. If not, your are allowed to download the folders and database. Thank you for your understanding.

October 11, 2018 at 3:30 pm #2809006

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for allowing me access to duplicate your site. I set up a copy of your site on my local environment. The only change I made was to disable the Really Simple SSL plugin. When I edit a Turkish page and change or add a link, I see a list of the Turkish pages. So unfortunately I'm not able to reproduce this issue on a test site.

Could you please ask your hosting provider if they are using server side caching? If so, perhaps they can disable it. Then clear your site cache and browser cache and test it the pages are showing correctly when you try to add a link. I can't think of why else it would work locally but not on your live site. It's very strange.

October 11, 2018 at 7:22 pm #2809602

UT

The server is our company's server. I can not see any server environment or configuration conflict at all. Do you suggest anything?

October 12, 2018 at 4:07 pm #2812592

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I don't see anything in the settings, but there could be something showing in the server logs that could point us in the right direction. Were you able to check the server log?

I don't suppose there is a chance you could set up a staging site on the same server?

When you disabled Sticky Links, did you revert the sticky links to permalinks? Please check out this section of the documentation. Maybe try adding this function to your theme functions.php and see if the pages show up? https://wpml.org/documentation/getting-started-guide/sticky-links/#linking-to-pages-in-a-different-language

The topic ‘[Closed] Existing content reads the data form the default language only’ is closed to new replies.