This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 2 months, 3 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 25, 2019 at 2:04 pm #4283949

jeroenB-6

I am trying to:

We use toolset so that a german user can only edit german translations. When we click on the edit button in a page as an admin we get the Advanced Translation Editor. But when I am logged in as the german user we get a different screen. How can we get the Advanced Translation Editor as the german user?

July 25, 2019 at 5:13 pm #4285339

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Please, try the following:

1 - Make sure you have set the WPML Advanced Translation Editor as you editor of choice in your WordPress Dashboard > WPML > Settings settings.

2 - Make sure you have sent some translation for your german users to translate it. From the screenshot provide it seems you don't have any translation job sent for translation. Here are the full details:

2.1 - Add the german translators for your website in your WordPress Dashboard > WPML > Translation Management > Translators tab

2.2 - Send a translation for the german translators added above.

2.3 - Log in as a german translator and go to your WordPress Dashboard > WPML > Translation > Management > Translations and click to translate the job sent in your previous step. You should see the Advanced Translation Editor as the editor of choice for your translations efforts.

See:

https://wpml.org/documentation/translating-your-contents/
https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/

Please, let me know if you need any additional assistance and clarifications, have a nice day.

July 29, 2019 at 8:12 am #4297651

jeroenB-6

Hi Marcos,

I understand what you say but the problem is that the german translator doesn't have acces to the advanced translation editor. Hoe can I give him acces to the editor? When I go to pages and click on the edit icon in the language I want to translate I go to the advanced translation edito where I can translate each string in the proper language but when I am logged in as the german translator I go to a different screen instead of the advanced translation editor. I want that the german translator also goed to the advanced translation editor. Cheers, Jeroen

July 30, 2019 at 1:16 am #4303951

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Jeroen,

Thank you for the updates. Can you please provide me with an adminand a german translator access details? This way I can try to replicate your issue and provide you with a detailed and accurate answer. Please, consider: I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

July 30, 2019 at 9:11 am #4305995
jeroenB-6

One other thing when we go to the homepage (emobility.blinktuit.nl) and click on the belgium flag it dosen't redirect to the belgium homepage language.

New threads created by Marcos Vinicios Barreto and linked to this one are listed below:

https://wpml.org/forums/topic/split-expected-another-screen-belgium-flag-it-dosent-redirect-to-the-belgium-homepage-language/

July 31, 2019 at 5:43 pm #4317089

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Jeroen,

Thank you for the details. I took a detailed look in your and noticed although you have a german user assigned as a german translatorn, you didn't proceed according our worflow when using the WPML Translation Management. Here is what you should try:

1 - Logged in as administrator go to your WordPress Dashboard > WPML > Translation Management click the 'Translation Dashboard' tab.

2 - Choose your desired page to be sent for translation by your german translator, in my case I chose the '404' page for test purposes. See attached screenshot (customer_screen_01).

3 - Send this page to be translated into the german language. See attached screenshot (customer_screen_02).

4 - Now click the 'Translation Basket' tab, choose your german translator user and click the 'Send all items for translation' button. See attached screenshot (customer_screen_03).

5 - Now access your WordPress Dashboard with your german user, go to yout WordPress Dashboard > Translations menu and click to translate the page content. You should now see the same translation editor you have setup in your website, in your case the WPML Advanced Translation Editor.

The cause of your issue: Instead of creating a translation job and sending it for translation as the steps above do, you are trying a direct access to your website dashboard with an user you have assigned for translation in your Translation Management settings, doing so you wouldn't have access to the WPML Translation Editors and its advantage as no translation job is created for this users.

See: https://wpml.org/documentation/translating-your-contents/

As regarding your belgium homepage, I will split this ticket into another specific ticket for this issue so we can keep things organized into a topic basis and this way make it easier for our customers to find solutions for their needs when searching our forum.

Hope it helps, have a nice day.