This thread is resolved. Here is a description of the problem and solution.

Problem:Extremely slow admin

page load is sometimes more then 4 minutes.

Solution:Please keep WPML & all related plugins enabled while we do these steps:

1. The WP Memory Limit needs to be increased. Minimum requirements are 128Mb, yours is currently 40Mb. https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php:

1 /** Memory Limit */ define('WP_MEMORY_LIMIT', '128M'); 2. If you haven't already, can you review the following article https://wpml.org/2012/01/can-your-site-run-faster/ to ensure all relevant steps were followed?

3. Confirm the following settings are OFF or Disabled in WPML: - Auto ID adjust state - Track where strings appear - Auto register strings

4. Can you tell me more information about the hardware including the CPU?

5. What type of hosting do you have? Shared, VPS, Dedicated, etc?

6. Do you know if object caching is part of your PHP setup? PHP < 5.5 should be APC. Newer versions should use the zend op cache, uAPC will also work though but is slower. 7. Can you confirm that you are still experiencing performance issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Fifteen) ? W3 total cache + WPML 8. Are you using a cache plugin such as W3 total cache? 9. Make sure Disk caching is disabled. 10. Try disabling the W3 total cache plugin.

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Please make sure to update to WPML to the latest and check our list of Known Issues before reporting

This topic contains 9 replies, has 2 voices.

Last updated by betB 3 years, 10 months ago.

Assigned support staff: Bobby.

Author Posts
April 22, 2016 at 2:15 pm #867307

betB

URL of (my) website where problem appears: hidden link

Hi, we have an extremely slow backend, page load is sometimes more then 4 minutes.
Is it possible for you to take a look and advice us on how to optimize our settings.

Thank you in advance,

Bet Bakker

April 22, 2016 at 4:18 pm #867438

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi Bet ,

Thank you for contacting WPML Support,

I understand you are having site performance issues. Since performance issues can be difficult to pinpoint, let's check a few variables and settings to narrow the issue. Please answer as many of these questions as you can. Contact your hosting provider, if necessary.

Please keep WPML & all related plugins enabled while we do these steps:

1. The WP Memory Limit needs to be increased. Minimum requirements are 128Mb, yours is currently 40Mb. https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php:

1
/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
2. If you haven't already, can you review the following article https://wpml.org/2012/01/can-your-site-run-faster/ to ensure all relevant steps were followed?

3. Confirm the following settings are OFF or Disabled in WPML:
- Auto ID adjust state
- Track where strings appear
- Auto register strings

4. Can you tell me more information about the hardware including the CPU?

5. What type of hosting do you have? Shared, VPS, Dedicated, etc?

6. Do you know if object caching is part of your PHP setup? PHP < 5.5 should be APC. Newer versions should use the zend op cache, uAPC will also work though but is slower.

7. Can you confirm that you are still experiencing performance issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Fifteen) ?

W3 total cache + WPML

8. Are you using a cache plugin such as W3 total cache?

9. Make sure Disk caching is disabled.

10. Try disabling the W3 total cache plugin.

Thank you for helping us pinpoint the issue. Feel free to add any other information you may have.

Kind Regards,
Bobby

April 25, 2016 at 8:20 am #868144

betB

Hi Bobby, thank you for your quick reply! We increased our memory limit now, working on the other issues and gathering information.

I need your help with disabling: Auto ID adjust. We use Max Megamenu plugin on this site and this needs Auto ID adjust to make the menu multilingual (hidden link.

I read the WPML article about manually implementing WPML’s icl_object_id function, and would like to try this in Max-megamenu plugin (on a localhost installation first). Can you give me some directions how to do this?

Thank you for your help.

Best regards,

Bet

April 25, 2016 at 12:47 pm #868391

betB

Hi Bobby, I have answers on the list you sent me and also made a debug query report which I can send separately if you need to see it.

Thank you for helping us.
kind regards, Bet
-------------------------
1. The WP Memory Limit needs to be increased. Minimum requirements are 128Mb, yours is currently 40Mb. https://wpml.org/home/minimum-requirements/

:Done!

3. Confirm the following settings are OFF or Disabled in WPML:
- Auto ID adjust state: Not yet, see my earlier reply.
- Track where strings appear: Done!
- Auto register strings: Done!

4. Can you tell me more information about the hardware including the CPU?

:Intel(R) Xeon(R) CPU E3-1220L V2 @ 2.30GHz

5. What type of hosting do you have? Shared, VPS, Dedicated, etc?

:Shared

6. Do you know if object caching is part of your PHP setup? PHP < 5.5 should be APC. Newer versions should use the zend op cache, uAPC will also work though but is slower.

:php 5.6 with opcache (host is working on php 7 with nginx together with apache)

7. Can you confirm that you are still experiencing performance issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Fifteen) ?

:I tried on localhost copy (on the live-site this is not possible at the moment) with WPML disabled and Twenty Fifteen. WP admin is much faster now.

W3 total cache + WPML

8. Are you using a cache plugin such as W3 total cache?
9. Make sure Disk caching is disabled.
10. Try disabling the W3 total cache plugin.

:W3 is disabled

April 25, 2016 at 3:05 pm #868528

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Thank you for providing me with this information !

You can install Query Monitor plugin to measure performances (if you have already done this then please share this with me )

Try to find specific pages from user’s sites, to use for your performance testing
Query Monitor provides generic and detailed reports: focus on queries per component to get the actual queries ran by WPML and add-ons

1. Run tests with (current theme +/- non-WPML related plugins) +/- WPML plugins
2. Run tests with (default WP theme +/- non-WPML related plugins) +/- WPML plugins

Kind Regads,
Bobby

April 29, 2016 at 12:43 pm #872064

betB

Hi Bobby, I installed Query monitor and have an enormous report with some mentions of slow queries and duplicate queries, which I don't know how to handle/solve.

Do you want to see the reports? If so, in which format can I send them to you?

Thanks,

best regards, Bet

May 2, 2016 at 2:14 pm #873279

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

May i kindly ask you to please share the results with me

you could take screenshots and share them on here with me if that is possible

May 3, 2016 at 7:04 am #873750

betB

Hi Bobby, we have an installation of the site on a new server, I want to make new reports this afternoon and send them to you.

Best regards,

Bet

May 4, 2016 at 12:42 am #874620

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you, i will wait for your update

May 20, 2016 at 12:24 pm #887031

betB

Hi Bobby, sorry for my late response, I am busy with a new project. I will come back on this in a few weeks. I will close the issue for now and start an new ticket.

Thank you for your help,

best regards, Bet