This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.35 hours from now. Thank you for your understanding.

Tagged: 

This topic contains 23 replies, has 2 voices.

Last updated by Carlos Rojas 1 month, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
June 7, 2019 at 9:46 am

przemyslawZ-3

For long time we have a problem with really slow backend of our site.

Query Monitor noticed between 40 to 80 slow query where caller is: "WPML_DB_Chunk->retrieve()"

I created dev site with no user/customer data so I can give you credentials.

June 7, 2019 at 11:36 am #3975945

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I kindly ask you to visit this link and apply suggested: https://wpml.org/faq/prevent-performance-issues-with-wpml/

Could you tell me the result of those steps?

Kind regards,
Carlos

June 7, 2019 at 1:56 pm #3976945

przemyslawZ-3

Hi, Carlos.

Well I tried it many times and just check up every setup (every thing is like in the manual You suggest).
PHP 7.2.14
MySQL 5.7.24
WP limit 512m
Still the same.
I have no idea what is the reason and work with the back end is really painful.

June 7, 2019 at 3:10 pm #3977327

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

I tried to access the site's backend but I always get redirected to /my-account/ page. Could you take a look at this?

Also, we might be facing a conflict with a third party functionality. I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update any outdated plugins and themes.
- Flush any cache memory that might exists.
- Deactivate all the plugins that are not related to WPML.
- Go to WPML -> Support -> Troubleshooting link -> Apply the troubleshooting steps pointed out in the attached image.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Regards,
Carlos

June 7, 2019 at 3:59 pm #3977569

przemyslawZ-3

Sorry Carlos!

I forget to change a user role to Admin. Now You can access to the site.

June 10, 2019 at 10:12 am #3986591

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for changing the role of the user.

I applied some troubleshooting steps in the site and leaved it in a minimal setup. As you can see in that state the issue disappeared. I kindly ask you to active the other plugins one bu one until you found the culprit.

Regards,
Carlos

June 10, 2019 at 2:33 pm #3988169

przemyslawZ-3

Sorry Carlos but I think the problem still occur.

Now we have only 6 plugins activated (5 is WPML, 1 query monitor) and 76 slow queries, 2 duplicated. The backend is still slow even without WooCommerce! I thing we have to dig deeper.

June 10, 2019 at 2:34 pm #3988177

przemyslawZ-3

here is PrtScn

June 11, 2019 at 10:23 am #3994151

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

As you can see in the attached image the load time was less than 2 seconds, which is a very good performance. It also means that WPML plugins are not the responsible for the performance issue as they were activated when I took this screenshot.

I recommend you to follow the steps I described in my previous message to be able to isolate who is causing the performance issue.

Note: The two slow queries are still there but they aren't affecting the performance in a significant way.

Regards,
Carlos

June 11, 2019 at 7:53 pm #3998327

przemyslawZ-3

Hi,

Yes Carlos, I done all steps you recommend. I also deleted empty string from data base (found somewhere in this forum).

Sometimes it loads OK and some times just terrible. Like in src attachment 8sec ! with just few plugins.

But...I thing I found really reason! The admin site cant found otgsPopoverTooltip.js and otgsPopoverTooltip.css so we get 404 so the load time is terrible. I have no idea what is otgsPopoverTooltip but when WPML is off there is no errors.

Have any idea? What it could be and more important how to rid with it?

Best regards,
P.

June 12, 2019 at 7:08 am
June 12, 2019 at 4:44 pm #4006229

przemyslawZ-3

HI,

I got Error: "Error! The destination database could not be validated. Please check the destination WordPress and retry." when I try migrate the site. Could You check please if the data You provide is correct?

June 13, 2019 at 5:43 am #4009547

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I just re-wrote the data of the migration site. Please try again and let me know the results.

Regards,
Carlos

June 13, 2019 at 10:55 am #4012119

przemyslawZ-3

Unfortunnatly do not work.

The sFTP Host/Server Address is 198.199.78.128 ??

Could you see please if I use correct data?

June 13, 2019 at 1:09 pm #4013185

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I created another test site and changed the migration information in my previous private message. Please use this new migration info and follow the steps described in this video to migrate the site: hidden link

Please let me know if the migration finished correctly.
Regards,
Carlos