Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 16 replies, has 3 voices.

Last updated by Shekhar Bhandari 3 weeks, 3 days ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
November 6, 2019 at 10:11 am #4896583

angeloL-6

Link to a page where the issue can be seen:

hidden link
hidden link
hidden link

I expected to see:

Fast website, this is the current setup:
- Server: Kinsta business (100$/month)
- Cloudflare CDN
- WProcket installed
- Flatsome theme (top selling on Envato) + WooCommerce

Instead, I got:

Extremely slow website especially when clicking on any language in the language switcher, takes seconds just to begin to load something after clicked.
Then, when it begins to load, the page takes 10/15 secs to load.
I know that cached pages load fast in my site, but, when not cached, it takes forever to load any page. And even if pages are cached the lang switcher still takes a lot of time to respond when clicked.
Hope you can help me because I think hosting, theme, cache and CDN are not the cause of slowness in this site.
Thank you

November 6, 2019 at 11:16 am #4897515

angeloL-6

Hi, I tested the website in a staging area with all plugins off except WPML and Woocommerce, it's faster but I can still see that pages load in 6 or 7 seconds, it's still too much.
What can I do now?

This is the address of my staging site:
hidden link

November 7, 2019 at 2:58 am #4902521

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

To debug this issue further, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

November 7, 2019 at 1:25 pm #4906149

angeloL-6

Just to give some additional info, I just tested a little bit the website and noticed some WPML slow queries (attached).

November 8, 2019 at 8:22 am #4911281

angeloL-6

Sorry in the meantime I worked in the staging site, try now.

November 8, 2019 at 11:26 am #4912751

angeloL-6

I'll add a screenshot, maybe it helps, I found out that there's a file taking quite 1 second to load in every page, maybe you know the reason.
Thanks

November 11, 2019 at 9:47 am #4923233

angeloL-6

HI,
Is there any news?
Thanks

November 11, 2019 at 10:44 am #4923795

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Is the migration completed? You can find more details about the migration and it's details in this private reply: https://wpml.org/forums/topic/extremely-slow-website/#post-4910771

Let me know once the migration is completed so I can test the issue in depth.

Thanks

November 11, 2019 at 10:48 am #4923801

angeloL-6

I sent the credentials for the staging website there 's no need to migrate. Can you log in the staging site? Thanks

November 11, 2019 at 10:59 am #4923939

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Yes, I have those login details, The reason I asked to migrate was also to check if it's also due to server you are experiencing those performance issues, it's always better to check the performance on different servers.

I hope this is OK and you can migrate the site. 🙂

Look forward to your reply.

Thanks

November 11, 2019 at 11:51 am #4924669

angeloL-6

Ok the migration has finished.
I'll wait for your response.
Thank you

November 12, 2019 at 3:29 pm #4932835

angeloL-6

Hi guys, any news on this ticket?
Does the site perform well on your server?
Thanks

November 13, 2019 at 9:12 am #4936739

angeloL-6

Hi,
I have a problem with images, but that's ok, doesn't matter.
Even without images I can see that loading time is quite high, as you can see from the attachment the TTFB of the main process requires about 5secs to load.

November 15, 2019 at 5:00 am #4951067

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello there,

I will handle your request from here, I am analyzing your staging site now. I will update you in a while.

Kind regards
Raja

November 15, 2019 at 6:11 am #4951175

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I have performed a few tests on your staging site. I have used to Query Monitor and Google Page speed tools for the tests

1) I have optimized the WPML string translation table from WPML > Support > troubleshooting page. After that, I don't see any slow queries from WPML anymore. I would recommend the same to be applied to your live site.
- Goto WPML > Support > troubleshooting
--- Click "Clear Cache with WPML"
--- Remove ghost entries
--- Clean up and Optimize String tables

2) I have subjected the Site to Google Page speed test hidden link With and Without WPML on the staging site. I could not see any huge or remarkable difference in page load time.
---Page Speed Index with WPML enabled: 4.4 s
--- Page Speed Index with WPML disabled: 3.5 s
Kindly check the attached screenshots

The difference of 1s is expected since WPML requires some resources for its execution. However, according to the google page test, the difference doesn't make any huge difference and the speed ranking is preferably good.

I would recommend performing Google Page speed test without WPML on your staging site follow the suggestions mentioned by Google. Once you have the right speed index Enable WPML, refresh the site and Subject the site to the Google page speed test again this will give you better results.

Let me know if you still need further assistance.

Kind regards
Raja

The topic ‘[Closed] Extremely slow website’ is closed to new replies.