This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Bruno 3 months, 1 week ago.

Assigned support staff: Bruno.

Author Posts
June 30, 2019 at 8:04 am #4113615

mennov-10

Dear support,

i've made a website with facetwp and wpml (2 languages = NL and EN).
I'am using custom post types and with facetwp i am using them to filter post types.

The facet is showing only one language. When i save the facet then he will switch but als on both pages with the same translation.

The post type is named:
NL -> Alle diensten
EN -> services

Example one is showing "services"
NL =
hidden link

Example two is showing "services"
EN =
hidden link

I've done reseach through the internet an tried different things like:
Disable all the other plugins
Activate a default theme
making new facet templates

Nothing works, please help me. It seems small but for me it's a big issue.
Thank you very much.

June 30, 2019 at 10:13 pm #4114993

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting. Where are these labels added? For example, in addition to "Services", the other labels are translated. How are these custom labels added?

Also, is this "Services" a custom label or is it the native label of FacetWP? If this is a custom label, which option you have changed to use "Services". Is this a FacetWP option?

Thank you.

July 1, 2019 at 5:08 am #4115599

mennov-10

Services is a filter based on a custom post type. The Other labels are also checkboxes, filtering from a post category and they're working fine.

Services is a default checkbox option from facetWP, filtering on post type. When i change the language the name won't change.

July 1, 2019 at 9:53 pm #4122241

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

I'll need to check your site to see how this is being done. I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

July 3, 2019 at 2:15 am #4130875

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you.

I'm still a bit confused about how this string is being added.

In my test environment, I noticed that after re-indexing, the correct string appears in Dutch, but the English string is also overwritten. I followed the steps below:

- Click on the Settings > FacetWP
- Click on the Re-index
- The string is now displayed as "Alle diensten"
- The English string, however, is not being displayed in the secondary language

Where exactly are these strings added? For example, if I want to change this string in this filter, what steps should I follow?

Thank you.

July 3, 2019 at 9:19 am #4133849

mennov-10

I changed the string in WPML (screen). In my opinion the facet should now change automaticly afters i switch languages?

July 4, 2019 at 5:08 pm #4145529

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

The question is that depending on how this is being inserted so that this filter is added.

So I asked earlier if it was necessary to change the default string, which steps I should follow. For example, I noticed that "Alle diensten" is defined within its theme (in the functions.php file), but even changing these labels, the string is not changed in the default language.

That is, I still do not understand how this filter is being added on the front-end. If it were necessary to change the string "Alle diensten" to "Alle diensten TEST" on the default language, what steps should I follow to see the result on the front end?

Thank you.

The topic ‘[Closed] FacetWP post type (checkbox) is random showing language’ is closed to new replies.