We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: TypeError: Failed to fetch advanced transation editor Solution: I noticed your website content is served over https while you have http as your setting in your WordPress Dashboard > Settings > General. Relevant Documentation: https://wpml.org/forums/topic/cannot-set-the-preferred-editor/#post-3025065

This topic contains 5 replies, has 2 voices.

Last updated by chantalS 5 months, 3 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
May 17, 2019 at 7:49 am #3831905

chantalS

Tell us what you are trying to do?
I'm trying to enable the advanced translation editor

Is there any documentation that you are following?
I've been following some steps I found in some tickets with the same issue. So I changed the config.php DEBUG from false to true and added 3 other required lines (INI). I deactivated all the plugins and changed the theme to Twenty Seventeen, but the issue isn't solved.

Is there a similar example that we can see?

What is the link to your site?
hidden link

May 17, 2019 at 8:42 am #3832431

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Thank you for contacting WPML support!

In order to debug this issue further quickly, would you be willing to provide me with temporary WordPress admin username and also a database access (perhaps cPanel) so I could investigate the issue directly? It may be related to nill class and ID number errors, we've had cases like this and were able to fix them only through direct database access.

I have marked your next reply private so you can safely add this information.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

May 17, 2019 at 10:16 am #3833281

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

I've checked inside and I think that this may be the reason:
https://wpml.org/forums/topic/cannot-set-the-preferred-editor/#post-3025065

According to that ticket, that was what fixed it.

Because when I check hidden link, it says "hidden link" for both, but your site is hidden link in fact.

These values seem to be hardcoded, since we can't change them through these settings:
https://codex.wordpress.org/Changing_The_Site_URL

Can you try changing the values if they are hard coded here (Edit wp-config.php) or perhaps within database? Can you ask your site developer (in case you didn't manage this part) to check this for you?

Regards,
Bruno Kos

May 17, 2019 at 11:06 am #3833755

chantalS

Thanks for your message. I informed the developer about this case and asked them to change it.

May 17, 2019 at 12:09 pm #3834267

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Ok, let me know how it goes or if you need further assistance!

Regards,
Bruno Kos

May 22, 2019 at 2:56 am #3860163

chantalS

My issue is resolved now. Thank you!