This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by valerioR 2 months, 1 week ago.

Assigned support staff: Noman.

Author Posts
August 6, 2019 at 3:35 pm #4349209

valerioR

I am trying to: use SEO Yoast

Link to a page where the issue can be seen: I am working locally

I expected to see: the SEO Yoast panel in the post editor

Instead, I got: I get this error "failed to initialize plugin: bs_component_buttons_script" and the panel is ugly (See attachment)

August 6, 2019 at 6:36 pm #4350049

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please follow below steps and let me know how it goes?

=== Please backup your database and website ===

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40MB as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

2. Please clear all sorts of caches in your site plugin cache (W3 Total Cache) / CDN cache (if any) / browser cache and then see if it resolves the issue afterwards.

3. If still issue persists, please follow these steps in order to isolate the cause of the issue:
- Backup your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see which one there is an interaction issue.

Thank you

August 6, 2019 at 9:38 pm #4350527

valerioR

Thanks a lot for your answer.
I did step 1,2 and 3. It seems the error comes when I activate the Toolset Types plugin.
What shall I do? Use another plugin instead?

August 7, 2019 at 8:54 am #4352961

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have noticed that you are using an older version of types plugin in your site. Can you please upgrade it to the latest version and I hope it will resolve your issue. You can download it from here:
https://toolset.com/home/types-manage-post-types-taxonomy-and-custom-fields/

Thank you

August 7, 2019 at 12:54 pm #4355243

valerioR

mmmh actually I don't have a premium license anymore so I can't upgrade it 🙁
I will check what I can do. Maybe I can reproduce the same CPT with another plugin or manually.
Any suggestion? 🙂

August 7, 2019 at 1:57 pm #4355761

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

As you only need the Types part, I will suggest the code generators that WordPress offers: hidden link

This is not the same as the GUI Types offers but it is very powerful if you at the end just need to create the data and display it within your templates using PHP or custom shortcodes.

Thank you

August 7, 2019 at 3:39 pm #4356545

valerioR

My issue is resolved now. Thank you! I can now activate Yoast and I don't see any problem