This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 4 replies, has 3 voices.

Last updated by Liviu Panuta 3 months, 1 week ago.

Assigned support staff: Noman.

Author Posts
June 11, 2019 at 1:50 pm #3995801

dr-ferdinandB

After installing and customization of WPML, the translated pages failed due the issue:
Failed to initialize plugin: tm_photo_gallery.
The issue is an image carousel, working in default language but not in translated pages

June 11, 2019 at 3:37 pm #3996849

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

- Please make sure minimum requirements for WPML meet:
https://wpml.org/home/minimum-requirements/

- Please make sure your theme is WPML compatible. Here is our compatible theme list. You can search your theme in this list. https://wpml.org/documentation/theme-compatibility

- Also make sure you are using an updated version of the theme and plugins.

- Please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

If the issue is gone, activate one by one to see which one there is an interaction issue.

Please let me know the results.

- Please add the debug report in the Debug Information box. I have also enabled debug info box for your next reply: https://wpml.org/faq/provide-debug-information-faster-support/

Thank you

June 12, 2019 at 8:46 am #4002057

dr-ferdinandB

Hi Noman,
thanks for your answer. The tm-photo-gallery works correctly in the default language English but it doesn't work in the translated languages GERMAN/HUNGARIAN/ROMANIAN. On these pages we receive the error message.
Attached you will find our debug information.

Have a nive day

June 12, 2019 at 2:43 pm #4005439

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

If still issue persists, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

July 4, 2019 at 6:49 am #4140519

Liviu Panuta

Hello,
How do you solve this problem? I have the same.
I added this code line:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

The topic ‘[Closed] Failed to initialize plugin: tm_photo_gallery in translated pages’ is closed to new replies.